summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-12-02 13:56:10 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-12-02 18:07:36 +0100
commite89aceab635ad053244586ef430162e4817d8f64 (patch)
tree93a83cf33134e4a25f67e2754e258241e3364217 /gnu/packages/ebook.scm
parentbf7ef1bb848db0977b54ea012789adc68751c68a (diff)
downloadguix-patches-e89aceab635ad053244586ef430162e4817d8f64.tar
guix-patches-e89aceab635ad053244586ef430162e4817d8f64.tar.gz
gnu: calibre: Do not use python setuptools for building.
* gnu/packages/ebook.scm (calibre)[arguments]: Set #:use-setuptools? to false.
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index ad1871688e..3843fb2092 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -126,6 +126,9 @@
`(#:python ,python-2
#:test-target "check"
#:tests? #f ; FIXME: enable once flake8 is packaged
+ ;; Calibre is using setuptools by itself, but the setup.py is not
+ ;; compatible with the shim wrapper (taken from pip) we are using.
+ #:use-setuptools? #f
#:phases
(modify-phases %standard-phases
(add-before 'build 'configure