summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2019-05-04 02:42:29 +1000
committerDanny Milosavljevic <dannym@scratchpost.org>2019-05-05 14:44:21 +0200
commitd6dfe8b6341be432d3a45e6ff86e78edb247f266 (patch)
tree13e428ce8c2648cbaa5f17c287732f35c17d5b2e /gnu/packages/ebook.scm
parentf3f017dbf0b52bba09ab8390c06cca5ff6030b8f (diff)
downloadguix-patches-d6dfe8b6341be432d3a45e6ff86e78edb247f266.tar
guix-patches-d6dfe8b6341be432d3a45e6ff86e78edb247f266.tar.gz
gnu: calibre: Install man pages.
* gnu/packages/ebook.scm (calibre)[arguments]<#:phases>[install-man-pages]: New phase. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 9408d5501d..257fbd2478 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -206,6 +206,12 @@
(invoke "python2" "setup.py" "mathjax""--system-mathjax" "--path-to-mathjax"
(string-append (assoc-ref inputs "js-mathjax") "/share/javascript/mathjax"))
(invoke "python2" "setup.py" "rapydscript")))
+ (add-after 'install 'install-man-pages
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively
+ "man-pages"
+ (string-append (assoc-ref outputs "out") "/share/man"))
+ #t))
;; The font TTF files are used in some miscellaneous tests, so we
;; unbundle them here to avoid patching the tests.
(add-after 'install 'unbundle-font-liberation