summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2020-09-13 15:45:54 +1000
committerLudovic Courtès <ludo@gnu.org>2021-04-22 14:04:27 +0200
commitb2b799e2d8330af934f48bf66afb5114addb4dd7 (patch)
tree8863ff1aa826ed98fcf237ff1279a6f6c445705a /gnu/packages/ebook.scm
parentd11574736207c69e40a5ee422e7b0465629a37cd (diff)
downloadguix-patches-b2b799e2d8330af934f48bf66afb5114addb4dd7.tar
guix-patches-b2b799e2d8330af934f48bf66afb5114addb4dd7.tar.gz
utils: Rename 'wrapper?' to 'wrapped-program?'.
* guix/build/utils.scm (wrap-program): The wrapper? procedure is incorrectly named as it actually checks to see if prog is the original program that was moved, not the wrapper. * guix/build/python-build-system: (wrap): Use renamed wrapped-program?. * gnu/packages/ebook.scm (calibre)[arguments]: Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 4731c0fa80..22a4b87e60 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -324,7 +324,7 @@ sip-include-dirs = [\"" pyqt "/share/sip" "\"]")))
;; rather than create ..calibre-real-real-s. For more
;; information see: https://issues.guix.gnu.org/43249.
(find-files "." (lambda (file stat)
- (not (wrapper? file)))))))
+ (not (wrapped-program? file)))))))
#t)))))
(home-page "https://calibre-ebook.com/")
(synopsis "E-book library management software")