summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2019-05-04 02:42:18 +1000
committerDanny Milosavljevic <dannym@scratchpost.org>2019-05-05 14:44:20 +0200
commitb01cde1ac98395d9a3007bf5329ebb7f860c13d0 (patch)
tree2cb824db5be137c913dad72d3df13baf010babac /gnu/packages/ebook.scm
parent15871b40872b9534a9dc3af9fda163601a360a51 (diff)
downloadguix-patches-b01cde1ac98395d9a3007bf5329ebb7f860c13d0.tar
guix-patches-b01cde1ac98395d9a3007bf5329ebb7f860c13d0.tar.gz
gnu: calibre: Disable tests that require networking.
* gnu/packages/ebook.scm (calibre)[arguments]<#:phases>[configure]: Modify. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 79fa99cf4a..2b557ab08d 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -185,6 +185,9 @@
"/bin/pdftohtml\"")))
(setenv "PODOFO_INC_DIR" (string-append podofo "/include/podofo"))
(setenv "PODOFO_LIB_DIR" (string-append podofo "/lib"))
+ ;; This informs the tests we are a continuous integration
+ ;; environment and thus have no networking.
+ (setenv "CI" "true")
#t)))
(add-after 'build 'build-extra
(lambda* (#:key inputs #:allow-other-keys)