summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-23 14:33:40 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-23 16:00:07 +0100
commitae16afe92e5564e64767e668b6f0c8ed972e2829 (patch)
treed622bc1d642489937fb5030e17b0e1840380a549 /gnu/packages/ebook.scm
parenta59f429ad1b3f95e70d7afe816d5cec05d598524 (diff)
downloadguix-patches-ae16afe92e5564e64767e668b6f0c8ed972e2829.tar
guix-patches-ae16afe92e5564e64767e668b6f0c8ed972e2829.tar.gz
gnu: calibre: Update to 3.17.0.
* gnu/packages/ebook.scm (calibre): Update to 3.17.0. [arguments]: End all phases with #t.
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 7d34bfafac..bb43000e81 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -74,7 +75,7 @@
(define-public calibre
(package
(name "calibre")
- (version "3.11.1")
+ (version "3.17.0")
(source
(origin
(method url-fetch)
@@ -83,7 +84,7 @@
version ".tar.xz"))
(sha256
(base32
- "0kwza7iyyyfhq476z5fk9962iyd0qpgmzm1k36nqcy8sfjbk8mrl"))
+ "1w6hw1s0d4daa4q2ykzhxdndiq61l8z7ls7rxh7k7p62ia0i5sxp"))
;; Remove non-free or doubtful code, see
;; https://lists.gnu.org/archive/html/guix-devel/2015-02/msg00478.html
(modules '((guix build utils)))
@@ -175,7 +176,8 @@
(substitute* "setup/build_environment.py"
(("sys.prefix") (string-append "'" pyqt "'")))
(setenv "PODOFO_INC_DIR" (string-append podofo "/include/podofo"))
- (setenv "PODOFO_LIB_DIR" (string-append podofo "/lib")))))
+ (setenv "PODOFO_LIB_DIR" (string-append podofo "/lib"))
+ #t)))
(add-after 'install 'install-font-liberation
(lambda* (#:key inputs outputs #:allow-other-keys)
(for-each (lambda (file)