summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-07 20:12:36 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-07 20:12:36 +0100
commit947ae54559634c84c78990384892273504f2378a (patch)
treeda242d7875c17243f65dbf0b448616a440fe9009 /gnu/packages/ebook.scm
parent85b5d3331d5c21aa06bad89a50c67e155fea0550 (diff)
downloadguix-patches-947ae54559634c84c78990384892273504f2378a.tar
guix-patches-947ae54559634c84c78990384892273504f2378a.tar.gz
gnu: Add chmlib.
* gnu/packages/ebook.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
new file mode 100644
index 0000000000..3236a5d669
--- /dev/null
+++ b/gnu/packages/ebook.scm
@@ -0,0 +1,40 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ebook)
+ #:use-module ((guix licenses) #:select (gpl3))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public chmlib
+ (package
+ (name "chmlib")
+ (version "0.40")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.jedrea.com/chmlib/chmlib-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "18zzb4x3z0d7fjh1x5439bs62dmgsi4c1pg3qyr7h5gp1i5xcj9l"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.jedrea.com/chmlib/")
+ (synopsis "Library for CHM files")
+ (description "CHMLIB is a library for dealing with ITSS/CHM format files.")
+ (license gpl3))) ; some files are under various other licenses, see COPYRIGHT