summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-14 14:17:47 -0500
committerLeo Famulari <leo@famulari.name>2022-01-14 14:45:17 -0500
commit873fda504c74115c2d0333687a6723b134257dac (patch)
treef3645d3bcded0cd9d4d991f1f738d1bc76b87214 /gnu/packages/ebook.scm
parent3a555a93a9f8e15095da8c79c7fa415ed21bf5b7 (diff)
downloadguix-patches-873fda504c74115c2d0333687a6723b134257dac.tar
guix-patches-873fda504c74115c2d0333687a6723b134257dac.tar.gz
gnu: Calibre: Fix a build failure with recent zeroconf.
Fixes <https://issues.guix.gnu.org/53247>. * gnu/packages/patches/calibre-fix-zeroconf.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ebook.scm (calibre)[source]: Use it.
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 03671ee902..207bbfcdaf 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -145,7 +145,8 @@ with Microsoft Compiled HTML (CHM) files")
(delete-file "resources/calibre-portable.bat")
(delete-file "resources/calibre-portable.sh")
#t))
- (patches (search-patches "calibre-no-updates-dialog.patch"
+ (patches (search-patches "calibre-fix-zeroconf.patch"
+ "calibre-no-updates-dialog.patch"
"calibre-remove-test-sqlite.patch" ; TODO: fix test.
"calibre-remove-test-unrar.patch"))))
(build-system python-build-system)