summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-08-15 20:47:08 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-08-17 01:56:38 +0200
commit84a52639c950a5e20cf999af788e1f7928dce83a (patch)
treec8a6cb151691b4785208ebb15bcebdb7196c9dd7 /gnu/packages/ebook.scm
parentf73f1f0769c56b15fb76d1deb52f6de1d599250d (diff)
downloadguix-patches-84a52639c950a5e20cf999af788e1f7928dce83a.tar
guix-patches-84a52639c950a5e20cf999af788e1f7928dce83a.tar.gz
gnu: Add liblinebreak.
* gnu/packages/ebook.scm (liblinebreak): New variable.
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 32f4f3b2d1..0880560222 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -195,3 +195,24 @@ ebooks for convenient reading.")
license:public-domain
license:silofl1.1
license:cc-by-sa3.0))))
+
+(define-public liblinebreak
+ (package
+ (name "liblinebreak")
+ (version "2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/vimgadgets"
+ "/liblinebreak/" version
+ "/liblinebreak-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1f36dbq7nc77lln1by2n1yl050g9dc63viawhs3gc3169mavm36x"))))
+ (build-system gnu-build-system)
+ (home-page "http://vimgadgets.sourceforge.net/liblinebreak/")
+ (synopsis "Library for detecting where linebreaks are allowed in text")
+ (description "@code{liblinebreak} is an implementation of the line
+breaking algorithm as described in Unicode 6.0.0 Standard Annex 14,
+Revision 26. It breaks lines that contain Unicode characters. It is
+designed to be used in a generic text renderer.")
+ (license license:zlib)))