summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
committerMarius Bakke <marius@gnu.org>2021-06-19 17:38:47 +0200
commit6f9a80b331ae41d142a49fbeb94b90ee587b6155 (patch)
tree2da042a6ccf5368c73d6e3d54c2ee02a62d284e4 /gnu/packages/ebook.scm
parent6500c9a5b364616e38a7e03aa4516fc2d7cee876 (diff)
parentdece03e2b98fc1c2428c2448ce5792f813eb79bf (diff)
downloadguix-patches-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar
guix-patches-6f9a80b331ae41d142a49fbeb94b90ee587b6155.tar.gz
Merge branch 'master' into core-updates
Note: this merge actually changes the 'curl' and 'python-attrs' derivations, as part of solving caf4a7a2770ef4d05a6e18f40d602e51da749ddc and 12964df69a99de6190422c752fef65ef813f3b6b respectively. 4604d43c0e (gnu: gnutls@3.6.16: Fix cross-compilation.) was ignored because it cannot currently be tested. Conflicts: gnu/local.mk gnu/packages/aidc.scm gnu/packages/boost.scm gnu/packages/curl.scm gnu/packages/nettle.scm gnu/packages/networking.scm gnu/packages/python-xyz.scm gnu/packages/tls.scm
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 708ef474fa..1fcee832a3 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -55,6 +55,7 @@
#:use-module (gnu packages libusb)
#:use-module (gnu packages libreoffice)
#:use-module (gnu packages music)
+ #:use-module (gnu packages pantheon)
#:use-module (gnu packages pdf)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -146,7 +147,7 @@ with Microsoft Compiled HTML (CHM) files")
(build-system python-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
- ("qtbase" ,qtbase) ; for qmake
+ ("qtbase" ,qtbase-5) ; for qmake
("python-flake8" ,python-flake8)
("python-pyqt-builder" ,python-pyqt-builder)
("xdg-utils" ,xdg-utils)))
@@ -474,7 +475,7 @@ following formats:
(define-public cozy
(package
(name "cozy")
- (version "0.9.4")
+ (version "1.0.3")
(source
(origin
(method git-fetch)
@@ -483,7 +484,7 @@ following formats:
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "182y6mkr39qgwk1n33nhfngqjyadrijiyfkzxydx9hfch302i8wz"))))
+ (base32 "0m0xiqpb87pwr3fhy0a4qxg67yjhwchcxj3x2anyy0li4inryxag"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -530,12 +531,14 @@ following formats:
("python" ,python-wrapper)))
(inputs
`(("file" ,file)
+ ("granite" ,granite)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gst-libav" ,gst-libav)
("gst-plugins-bad" ,gst-plugins-bad)
("gst-plugins-good" ,gst-plugins-good)
("gst-plugins-ugly" ,gst-plugins-ugly)
("gtk+" ,gtk+)
+ ("libgee" ,libgee)
("libhandy" ,libhandy)
("python-distro" ,python-distro)
("python-gst" ,python-gst)