summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-31 14:28:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-31 14:28:56 +0200
commit6a2e54236e1b2c428c8fd478ee0f3bd8130703fa (patch)
treeaf70155a2f474d35d90d003f8584b2d9ee0bbaa8 /gnu/packages/ebook.scm
parent2cf1e37c109c8d03fae75bc84f7012f3afa956e5 (diff)
parent3d88855dfdcc4c8ce11f494fdf9f0ac1d8eef530 (diff)
downloadguix-patches-6a2e54236e1b2c428c8fd478ee0f3bd8130703fa.tar
guix-patches-6a2e54236e1b2c428c8fd478ee0f3bd8130703fa.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 5062515cf0..4c3efbfe02 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -57,7 +57,8 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
- #:use-module (gnu packages xorg))
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages wxwidgets))
(define-public chmlib
(package
@@ -332,3 +333,27 @@ following formats:
@item XHTML
@end enumerate")
(license license:gpl2+)))
+
+(define-public xchm
+ (package
+ (name "xchm")
+ (version "1.30")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/rzvncj/xCHM"
+ "/releases/download/"
+ version "/xchm-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1865wb3ppmx5y12rqfhv4wri0lfdah41zsfz94xb8gym80m8zac5"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("wxwidgets" ,wxwidgets)
+ ("chmlib" ,chmlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/rzvncj/xCHM")
+ (synopsis "CHM file viewer")
+ (description "xCHM is a graphical CHM file viewer. It is a frontend to
+the CHM library CHMLIB.")
+ (license license:gpl2+)))