summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <brendan.tildesley@openmailbox.org>2017-05-13 23:24:06 +1000
committerMarius Bakke <mbakke@fastmail.com>2017-05-19 23:49:21 +0200
commit29ec0851707f99fdd14b8c06c26759b98046a8f3 (patch)
tree8c3972693ad30d0a57cc4138427ce48365290cdf /gnu/packages/ebook.scm
parentd94a99ec665d9c58a534953d877305ad82b10e71 (diff)
downloadguix-patches-29ec0851707f99fdd14b8c06c26759b98046a8f3.tar
guix-patches-29ec0851707f99fdd14b8c06c26759b98046a8f3.tar.gz
gnu: calibre: Unbundle python2-markdown.
* gnu/packages/ebook.scm (calibre)[snippet]: Replace python references to bundled markdown with packaged. Remove markdown from source. [inputs]: Add python2-markdown as a dependency. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 70ec9ed352..e75183185e 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -78,8 +78,12 @@
(modules '((guix build utils)))
(snippet
'(begin
+ (delete-file-recursively "src/calibre/ebooks/markdown")
(delete-file-recursively "src/unrar")
- (delete-file "src/odf/thumbnail.py")))
+ (delete-file "src/odf/thumbnail.py")
+ (substitute* (find-files "." "\\.py")
+ (("calibre\\.ebooks\\.markdown") "markdown"))
+ #t))
(patches (search-patches "calibre-drop-unrar.patch"
"calibre-use-packaged-feedparser.patch"
"calibre-dont-load-remote-icons.patch"
@@ -120,6 +124,7 @@
("python2-dbus" ,python2-dbus)
("python2-feedparser" ,python2-feedparser)
("python2-lxml" ,python2-lxml)
+ ("python2-markdown" ,python2-markdown)
("python2-mechanize" ,python2-mechanize)
("python2-netifaces" ,python2-netifaces)
("python2-pillow" ,python2-pillow)