summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-07-19 12:40:03 +0200
committerRutger Helling <rhelling@mykolab.com>2019-07-19 12:41:02 +0200
commit04842543e8231d99aad4c8ec232f41272886fbd1 (patch)
tree13857d9448d051237587cf720d312ebc61f50803 /gnu/packages/ebook.scm
parent1a58e1d4442cb4ba504fd76b9567da9aef47b1b0 (diff)
downloadguix-patches-04842543e8231d99aad4c8ec232f41272886fbd1.tar
guix-patches-04842543e8231d99aad4c8ec232f41272886fbd1.tar.gz
gnu: fbreader: Build with GCC 5.
* gnu/packages/ebook.scm (fbreader)[native-inputs]: Add GCC-5.
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index cf424f285d..5062515cf0 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
#:use-module (gnu packages glib)
@@ -294,7 +295,8 @@ designed to be used in a generic text renderer.")
("sqlite" ,sqlite)
("zlib" ,zlib)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("gcc" ,gcc-5)
+ ("pkg-config" ,pkg-config)))
(arguments
`(#:tests? #f ; No tests exist.
#:make-flags `("CC=gcc" "TARGET_ARCH=desktop" "UI_TYPE=gtk"