summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-08-25 20:15:40 +0200
committerRoel Janssen <roel@gnu.org>2017-09-06 12:42:57 +0200
commit026ebc141ff9eb6147c9538f004119193d4cfe49 (patch)
treee39c632e29799f9e87f754cfbf48a540de1a8a44 /gnu/packages/ebook.scm
parent13be557d985ebc3770f28188f3ce45c2392c6c1d (diff)
downloadguix-patches-026ebc141ff9eb6147c9538f004119193d4cfe49.tar
guix-patches-026ebc141ff9eb6147c9538f004119193d4cfe49.tar.gz
gnu: Update calibre to 3.6.0.
* gnu/local.mk: Remove calibre-drop-unrar.patch * gnu/packages/ebook.scm (calibre): Update to 3.6.0. Add python-html5-parser input. * gnu/packages/patches/calibre-drop-unrar.patch: Remove file.
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 38abf47c87..4bcaa0abfe 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -72,7 +72,7 @@
(define-public calibre
(package
(name "calibre")
- (version "3.0.0")
+ (version "3.6.0")
(source
(origin
(method url-fetch)
@@ -81,21 +81,19 @@
version ".tar.xz"))
(sha256
(base32
- "1zhk7bvgr973dd18x4wp48kzai29qqqi5qcy72sxc4wcbk2sbnkw"))
+ "0vp2nds4b5xbchsh1rpc1q7093gd26dnw7mgbnax97dcchvlc4sc"))
;; Remove non-free or doubtful code, see
;; https://lists.gnu.org/archive/html/guix-devel/2015-02/msg00478.html
(modules '((guix build utils)))
(snippet
'(begin
(delete-file-recursively "src/calibre/ebooks/markdown")
- (delete-file-recursively "src/unrar")
(delete-file "src/odf/thumbnail.py")
(delete-file-recursively "resources/fonts/liberation")
(substitute* (find-files "." "\\.py")
(("calibre\\.ebooks\\.markdown") "markdown"))
#t))
- (patches (search-patches "calibre-drop-unrar.patch"
- "calibre-use-packaged-feedparser.patch"
+ (patches (search-patches "calibre-use-packaged-feedparser.patch"
"calibre-no-updates-dialog.patch"))))
(build-system python-build-system)
(native-inputs
@@ -129,6 +127,7 @@
("python2-dbus" ,python2-dbus)
("python2-dnspython" ,python2-dnspython)
("python2-feedparser" ,python2-feedparser)
+ ("python2-html5-parser" ,python2-html5-parser)
("python2-lxml" ,python2-lxml)
("python2-markdown" ,python2-markdown)
("python2-mechanize" ,python2-mechanize)
@@ -140,6 +139,9 @@
("python2-pyqt" ,python2-pyqt)
("python2-sip" ,python2-sip)
("python2-regex" ,python2-regex)
+ ;; python2-unrardll is needed for decompressing RAR files.
+ ;; A program called 'pdf2html' is needed for reading PDF books
+ ;; in the web interface.
("sqlite" ,sqlite)))
(arguments
`(#:python ,python-2