summaryrefslogtreecommitdiff
path: root/gnu/packages/easyrpg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/easyrpg.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/easyrpg.scm')
-rw-r--r--gnu/packages/easyrpg.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/easyrpg.scm b/gnu/packages/easyrpg.scm
index 2350efdb79..007e7ce5bc 100644
--- a/gnu/packages/easyrpg.scm
+++ b/gnu/packages/easyrpg.scm
@@ -51,7 +51,7 @@
"0n2k4brd264jg9p6918x7dnb2iimpzjh8q3v1fws58450xbgnkqc"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(propagated-inputs
;; Required by 'liblcf.pc'.
`(("expat" ,expat)
@@ -91,23 +91,23 @@ It can read and write LCF and XML files.")
(list (string-append "--with-bash-completion-dir="
%output "/etc/bash_completion.d/"))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("freetype" ,freetype)
- ("harfbuzz" ,harfbuzz)
- ("liblcf" ,liblcf)
- ("libpng" ,libpng)
- ("libsndfile" ,libsndfile)
- ("libvorbis" ,libvorbis)
- ("libxmp" ,libxmp)
- ("mpg123" ,mpg123)
- ("opusfile" ,opusfile)
- ("pixman" ,pixman)
- ("sdl2-mixer" ,sdl2-mixer)
- ("sdl2" ,sdl2)
- ("speexdsp" ,speexdsp)
- ("wildmidi" ,wildmidi)
- ("zlib" ,zlib)))
+ (list freetype
+ harfbuzz
+ liblcf
+ libpng
+ libsndfile
+ libvorbis
+ libxmp
+ mpg123
+ opusfile
+ pixman
+ sdl2-mixer
+ sdl2
+ speexdsp
+ wildmidi
+ zlib))
(home-page "https://easyrpg.org/")
(synopsis "Play RPG Maker 2000 and 2003 games")
(description