summaryrefslogtreecommitdiff
path: root/gnu/packages/dunst.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2017-09-22 12:28:01 +0300
committerAlex Kost <alezost@gmail.com>2017-09-28 18:41:17 +0300
commit9c074e89b1a22db8f9a5689bc9bfa3be743929d7 (patch)
tree431cb06c1bda50a5fe61cb66b585aa93dfa4b18a /gnu/packages/dunst.scm
parent1210046d768a47af9cf25506dd8e3dd0ae71841c (diff)
downloadguix-patches-9c074e89b1a22db8f9a5689bc9bfa3be743929d7.tar
guix-patches-9c074e89b1a22db8f9a5689bc9bfa3be743929d7.tar.gz
gnu: dunst: Update to 1.2.0.
* gnu/packages/dunst.scm (dunst): Update to 1.2.0. [inputs]: Update: remove 'libxext' and 'libxft', add 'gtk' and 'libxrandr'. [home-page]: Update for the new location.
Diffstat (limited to 'gnu/packages/dunst.scm')
-rw-r--r--gnu/packages/dunst.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/dunst.scm b/gnu/packages/dunst.scm
index d5e177f0ce..68637ea6cd 100644
--- a/gnu/packages/dunst.scm
+++ b/gnu/packages/dunst.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
+;;; Copyright © 2015, 2017 Alex Kost <alezost@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,15 +32,16 @@
(define-public dunst
(package
(name "dunst")
- (version "1.1.0")
+ (version "1.2.0")
(source (origin
(method url-fetch)
(uri (string-append
- "http://knopwob.org/public/dunst-release/dunst-"
- version ".tar.bz2"))
+ "https://github.com/dunst-project/dunst/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0w3hilzwanwsp4q6dxbdj6l0mvpg4fq02wf8isll8kmbx9kz2ay7"))))
+ "1bf5fmmj79wlwi8wzir3rd8czyrxfx16w8q7c957123yz1g5ph53"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no check target
@@ -55,15 +56,15 @@
(inputs
`(("dbus" ,dbus)
("glib" ,glib)
+ ("gtk" ,gtk+-2)
("cairo" ,cairo)
("pango" ,pango)
("libx11" ,libx11)
- ("libxext" ,libxext)
- ("libxft" ,libxft)
("libxscrnsaver" ,libxscrnsaver)
("libxinerama" ,libxinerama)
+ ("libxrandr" ,libxrandr)
("libxdg-basedir" ,libxdg-basedir)))
- (home-page "http://knopwob.org/dunst")
+ (home-page "https://dunst-project.org/")
(synopsis "Customizable and lightweight notification daemon")
(description
"Dunst is a highly configurable and minimalistic notification daemon.