summaryrefslogtreecommitdiff
path: root/gnu/packages/dunst.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/dunst.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/dunst.scm')
-rw-r--r--gnu/packages/dunst.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/dunst.scm b/gnu/packages/dunst.scm
index 2449620891..998470e411 100644
--- a/gnu/packages/dunst.scm
+++ b/gnu/packages/dunst.scm
@@ -63,22 +63,21 @@
#:phases (modify-phases %standard-phases
(delete 'configure))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("perl" ,perl) ; for pod2man
- ("which" ,which)))
+ (list pkg-config perl ; for pod2man
+ which))
(inputs
- `(("dbus" ,dbus)
- ("librsvg" ,librsvg) ; for svg support
- ("glib" ,glib)
- ("cairo" ,cairo)
- ("pango" ,pango)
- ("libnotify" ,libnotify) ; for dunstify
- ("libx11" ,libx11)
- ("libxscrnsaver" ,libxscrnsaver)
- ("libxinerama" ,libxinerama)
- ("libxrandr" ,libxrandr)
- ("libxdg-basedir" ,libxdg-basedir)
- ("wayland" ,wayland))) ; for wayland support
+ (list dbus
+ librsvg ; for svg support
+ glib
+ cairo
+ pango
+ libnotify ; for dunstify
+ libx11
+ libxscrnsaver
+ libxinerama
+ libxrandr
+ libxdg-basedir
+ wayland)) ; for wayland support
(home-page "https://dunst-project.org/")
(synopsis "Customizable and lightweight notification daemon")
(description