summaryrefslogtreecommitdiff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-07-04 21:32:31 +0200
committerRoel Janssen <roel@gnu.org>2016-07-04 21:32:31 +0200
commitfa8af53e99afd932b2e534a428ea6ac62581c89d (patch)
tree27d78a4b423b5e32f741178aa4ed8ccae54d16b1 /gnu/packages/documentation.scm
parent42c4b24646a9387a7d64a5cc646810c7727585c8 (diff)
downloadguix-patches-fa8af53e99afd932b2e534a428ea6ac62581c89d.tar
guix-patches-fa8af53e99afd932b2e534a428ea6ac62581c89d.tar.gz
gnu: Add scrollkeeper.
* gnu/packages/documentation.scm (scrollkeeper): New variable.
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 17a69e2c25..8302cc49cc 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,9 +28,11 @@
#:use-module (gnu packages)
#:use-module (gnu packages python)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages flex)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages perl)
#:use-module (gnu packages xml)
#:autoload (gnu packages zip) (unzip))
@@ -115,3 +118,38 @@ generate both TeX output for high-quality hardcopies or HTML output for online
brwosing. The documentation is extracted directly from the C/C++/IDL source
or Java class files.")
(license gpl2+)))
+
+(define-public scrollkeeper
+ (package
+ (name "scrollkeeper")
+ (version "0.3.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/scrollkeeper/scrollkeeper-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1bfxwxc1ngh11v36z899sz9qam366r050fhkyb5adv65lb1x62sa"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-xml-catalog="
+ (assoc-ref %build-inputs "docbook-xml")
+ "/xml/dtd/docbook/catalog.xml"))))
+ (inputs
+ `(("perl" ,perl)
+ ("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)
+ ;; The configure script checks for either version 4.2 or 4.1.2.
+ ("docbook-xml" ,docbook-xml-4.2)))
+ (native-inputs
+ `(("intltool" ,intltool)))
+ (home-page "http://scrollkeeper.sourceforge.net/")
+ (synopsis "Open Documentation Cataloging Project")
+ (description "ScrollKeeper is a cataloging system for documentation on open
+systems. It manages documentation metadata as specified by the Open Source
+Metadata Framework and provides a simple API to allow help browsers to find,
+sort, and search the document catalog. It will also be able to communicate
+with catalog servers on the Net to search for documents which are not on the
+local system.")
+ (license lgpl2.1+)))