summaryrefslogtreecommitdiff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-03-16 10:18:21 -0500
committerEric Bavier <bavier@member.fsf.org>2016-05-12 19:59:52 +0000
commitb4e655e5f1ce3064c805f1ff4c0b6693d52814e0 (patch)
tree3ebb34bfae7cef1f6e072f2859c23a148ddbcf7f /gnu/packages/documentation.scm
parent0573a923def01e54bf104e0015ade44ab42f694f (diff)
downloadguix-patches-b4e655e5f1ce3064c805f1ff4c0b6693d52814e0.tar
guix-patches-b4e655e5f1ce3064c805f1ff4c0b6693d52814e0.tar.gz
gnu: Add doc++.
* gnu/packages/documentation.scm (doc++): New variable. * gnu/packages/patches/doc++-include-directives.patch, gnu/packages/patches/doc++-segfault-fix.patch: New files. * gnu-system.am (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 567669a3b6..17a69e2c25 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2016 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
#:use-module (gnu packages graphviz)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages perl)
#:use-module (gnu packages xml)
#:autoload (gnu packages zip) (unzip))
@@ -87,3 +89,29 @@ programming languages such as C, Objective-C, C#, PHP, Java, Python,
IDL (Corba, Microsoft, and UNO/OpenOffice flavors), Fortran, VHDL, Tcl,
and to some extent D.")
(license gpl3+)))
+
+(define-public doc++
+ (package
+ (name "doc++")
+ (version "3.4.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://sourceforge.net/projects/docpp/"
+ "files/doc++-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0i37zlxl8g352s4hzpdx0657k5x3czh3xcsfr27irc708gb277pn"))
+ (patches (search-patches "doc++-include-directives.patch"
+ "doc++-segfault-fix.patch"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("flex" ,flex)
+ ("gettext" ,gnu-gettext)))
+ (home-page "http://docpp.sourceforge.net/")
+ (synopsis "Documentation system for C, C++, IDL, and Java")
+ (description
+ "DOC++ is a documentation system for C, C++, IDL, and Java. It can
+generate both TeX output for high-quality hardcopies or HTML output for online
+brwosing. The documentation is extracted directly from the C/C++/IDL source
+or Java class files.")
+ (license gpl2+)))