summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2016-01-11 13:36:26 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-01-14 09:17:12 -0500
commitdf1f1d693665bdbaeade86632636377dfe0d1767 (patch)
treed08429d0627d5517d8ae46149ff95c7b899b9873 /gnu/packages/docker.scm
parentb42c9c812403074ac0eaa57f9293972a5765e213 (diff)
downloadguix-patches-df1f1d693665bdbaeade86632636377dfe0d1767.tar
guix-patches-df1f1d693665bdbaeade86632636377dfe0d1767.tar.gz
gnu: Add docker-compose.
* gnu/packages/docker.scm (docker-compose): New variable.
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index f2164213d4..06b72ee376 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -71,3 +71,37 @@ management tool.")
pseudo-terminal (PTY) allocated to a Docker container using the Python
client.")
(license license:asl2.0)))
+
+(define-public docker-compose
+ (package
+ (name "docker-compose")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "docker-compose" version))
+ (sha256
+ (base32
+ "0ksg7hm2yvc977968dixxisrhcmvskzpcx3pz0v1kazrdqp7xakr"))))
+ (build-system python-build-system)
+ ;; TODO: Tests require running Docker daemon.
+ (arguments '(#:tests? #f))
+ (inputs
+ `(("python-docker-py" ,python-docker-py)
+ ("python-dockerpty" ,python-dockerpty)
+ ("python-docopt" ,python-docopt)
+ ("python-enum34" ,python-enum34)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-requests" ,python-requests-2.7)
+ ("python-setuptools" ,python-setuptools)
+ ("python-six" ,python-six)
+ ("python-texttable" ,python-texttable)
+ ("python-websocket-client" ,python-websocket-client)))
+ (home-page "https://www.docker.com/")
+ (synopsis "Multi-container orchestration for Docker")
+ (description "Docker Compose is a tool for defining and running
+multi-container Docker applications. A Compose file is used to configure an
+application’s services. Then, using a single command, the containers are
+created and all the services are started as specified in the configuration.")
+ (license license:asl2.0)))