summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-04-05 02:32:40 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-05 20:14:15 -0400
commit9c0244abbd1f56bd49b2dbbd274678c7d8d92a22 (patch)
tree1dbe5680512357ed8efd20b8e8492881b0bd3ff8 /gnu/packages/docker.scm
parent626de0d13a7307e8c1f505c83c29e8d6cfa391f6 (diff)
downloadguix-patches-9c0244abbd1f56bd49b2dbbd274678c7d8d92a22.tar
guix-patches-9c0244abbd1f56bd49b2dbbd274678c7d8d92a22.tar.gz
gnu: Add docker-libnetwork.
* gnu/packages/docker.scm (docker-libnetwork): New private variable.
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 39e7e8108b..25395fecd9 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -227,6 +227,44 @@ network attachments.")
(home-page "http://containerd.io/")
(license license:asl2.0)))
+;;; Private package that shouldn't be used directly; its purposes is to be
+;;; used as a template for the various packages it contains. It doesn't build
+;;; anyway, as it needs many dependencies that aren't being satisfied.
+(define docker-libnetwork
+ ;; There are no recent release for libnetwork, so choose the last commit of
+ ;; the branch that Docker uses, as can be seen in the Docker source file
+ ;; 'hack/dockerfile/install/proxy.installer'.
+ (let ((commit "4725f2163fb214a6312f3beae5991f838ec36326")
+ (version "18.09")
+ (revision "1"))
+ (package
+ (name "docker-libnetwork")
+ (version (git-version version "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/docker/libnetwork.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zpnxki8qfzha6ljahpwd3vkzmjhsvkmf73w6crm4ilxxw5vnpfb"))
+ ;; Delete bundled ("vendored") free software source code.
+ (modules '((guix build utils)))
+ (snippet '(begin
+ (delete-file-recursively "vendor")
+ #t))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/docker/libnetwork/"))
+ (home-page "https://github.com/docker/libnetwork/")
+ (synopsis "Networking for containers")
+ (description "Libnetwork provides a native Go implementation for
+connecting containers. The goal of @code{libnetwork} is to deliver a robust
+container network model that provides a consistent programming interface and
+the required network abstractions for applications.")
+ (license license:asl2.0))))
+
;; TODO: Patch out modprobes for ip_vs, nf_conntrack,
;; brige, nf_conntrack_netlink, aufs.
(define-public docker