summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-01-03 02:34:33 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-02-10 17:00:24 +0100
commit8c7eb58453870f380a077c7cfd8dafa97bb8e13f (patch)
tree0926d913920d76c89ca5fdf9d13d7a49dc9ae4fe /gnu/packages/docker.scm
parentd78178fa489c73713d555d2a70dd2bd5e3e5553d (diff)
downloadguix-patches-8c7eb58453870f380a077c7cfd8dafa97bb8e13f.tar
guix-patches-8c7eb58453870f380a077c7cfd8dafa97bb8e13f.tar.gz
gnu: docker: Update to 19.03.5.
* gnu/packages/docker.scm (docker-cli): Update to 19.03.5. (docker)[source]: Remove patches. [arguments]<#:phases>[patch-paths]: Modify. [native-inputs]: Add gotestsum. * gnu/packages/patches/docker-adjust-tests-for-changes-in-go.patch: Delete file. * gnu/packages/patches/docker-engine-test-noinstall.patch: Delete file. * gnu/packages/patches/docker-use-fewer-modprobes.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 948cc30cf6..a15c5d6004 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -46,7 +46,7 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages virtualization))
-(define %docker-version "18.09.5")
+(define %docker-version "19.03.5")
(define-public python-docker-py
(package
@@ -313,12 +313,9 @@ built-in registry server of Docker.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0cirpd9l2qazp2jyanwzvrkx2m98nksjdvn43ff38p89w6133ipb"))
+ (base32 "1dlknwn0fh82nbzdzxdk6pfhqwph9vcw3vs3111wfr19y5hwncq9"))
(patches
- (search-patches "docker-engine-test-noinstall.patch"
- "docker-fix-tests.patch"
- "docker-use-fewer-modprobes.patch"
- "docker-adjust-tests-for-changes-in-go.patch"))))
+ (search-patches "docker-fix-tests.patch"))))
(build-system gnu-build-system)
(arguments
`(#:modules
@@ -419,6 +416,7 @@ built-in registry server of Docker.")
"/" relative-path
"\"")) ...)))))
(substitute-LookPath*
+ ("containerd" "containerd" "bin/containerd")
("ps" "procps" "bin/ps")
("mkfs.xfs" "xfsprogs" "bin/mkfs.xfs")
("lvmdiskscan" "lvm2" "sbin/lvmdiskscan")
@@ -558,6 +556,7 @@ built-in registry server of Docker.")
(native-inputs
`(("eudev" ,eudev) ; TODO: Should be propagated by lvm2 (.pc -> .pc)
("go" ,go)
+ ("gotestsum" ,gotestsum)
("pkg-config" ,pkg-config)))
(synopsis "Docker container component library, and daemon")
(description "This package provides a framework to assemble specialized
@@ -579,7 +578,7 @@ provisioning etc.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0mxxjzkwdny8p2dmyjich7x1gn7hdlfppzjy2skk2k5bwv7nxpmi"))))
+ (base32 "07ldz46y74b3la4ah65v5bzbfx09yy6kncvxrr0zfx0s1214ar3m"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/docker/cli"