summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorJesse Dowell <jessedowell@gmail.com>2020-09-19 12:08:27 -0400
committerEfraim Flashner <efraim@flashner.co.il>2020-09-21 13:18:24 +0300
commit87a13a5e302f64e3ab6c7494242375f96dc83d6a (patch)
treefb1f2a6b93c10f72d6489d9b020327c32866d9e3 /gnu/packages/docker.scm
parent921fad1a5adc3e0fc4fadc544f8994475f27436d (diff)
downloadguix-patches-87a13a5e302f64e3ab6c7494242375f96dc83d6a.tar
guix-patches-87a13a5e302f64e3ab6c7494242375f96dc83d6a.tar.gz
gnu: docker: Synchronize docker dependencies with the current version of docker.
* gnu/packages/docker.scm (docker-libnetwork): Update to 19.03-1.026aaba. [source]: Follow URI redirection. [arguments]: Adjust import-path accordingly. [home-page]: Same. * gnu/packages/networking.scm (go-sctp): Update to 0.0.0-2.6e2cb13. [arguments]: Skip test suite. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index bc7e02ec46..783e19db9b 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright © 2020 Jesse Dowell <jessedowell@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,6 +49,8 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages virtualization))
+;; Note - when changing Docker versions it is important to update the versions
+;; of several associated packages (docker-libnetwork and go-sctp).
(define %docker-version "19.03.12")
(define-public python-docker
@@ -246,22 +249,25 @@ network attachments.")
(define docker-libnetwork
;; There are no recent release for libnetwork, so choose the last commit of
;; the branch that Docker uses, as can be seen in the Docker source file
- ;; 'hack/dockerfile/install/proxy.installer'.
- (let ((commit "4725f2163fb214a6312f3beae5991f838ec36326")
- (version "18.09")
+ ;; 'hack/dockerfile/install/proxy.installer'. NOTE - It is important that
+ ;; this version is kept in sync with the version of Docker being used.
+ ;; This commit is the "bump_19.03" branch, as mentioned in Docker's vendor.conf.
+ (let ((commit "026aabaa659832804b01754aaadd2c0f420c68b6")
+ (version (version-major+minor %docker-version))
(revision "1"))
(package
(name "docker-libnetwork")
- (version (git-version version "1" commit))
+ (version (git-version version revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/docker/libnetwork")
+ ;; Redirected from github.com/docker/libnetwork.
+ (url "https://github.com/moby/libnetwork")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "1zpnxki8qfzha6ljahpwd3vkzmjhsvkmf73w6crm4ilxxw5vnpfb"))
+ "0bli21vn5v7bssw3ydym4jfdjsldhb47fld88kng7d138wl70lkw"))
;; Delete bundled ("vendored") free software source code.
(modules '((guix build utils)))
(snippet '(begin
@@ -269,8 +275,8 @@ network attachments.")
#t))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/docker/libnetwork/"))
- (home-page "https://github.com/docker/libnetwork/")
+ `(#:import-path "github.com/moby/libnetwork/"))
+ (home-page "https://github.com/moby/libnetwork/")
(synopsis "Networking for containers")
(description "Libnetwork provides a native Go implementation for
connecting containers. The goal of @code{libnetwork} is to deliver a robust