summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/docker.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm60
1 files changed, 23 insertions, 37 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 472c5eb957..cdf62f5e9a 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -69,13 +69,10 @@
;; TODO: Tests require a running Docker daemon.
(arguments '(#:tests? #f))
(inputs
- `(("python-requests" ,python-requests)
- ("python-six" ,python-six)
- ("python-urllib3" ,python-urllib3)))
+ (list python-requests python-six python-urllib3))
(propagated-inputs
- `(("python-docker-pycreds" ,python-docker-pycreds)
- ("python-paramiko" ,python-paramiko) ;adds SSH support
- ("python-websocket-client" ,python-websocket-client)))
+ (list python-docker-pycreds python-paramiko ;adds SSH support
+ python-websocket-client))
(home-page "https://github.com/docker/docker-py/")
(synopsis "Python client for Docker")
(description "Docker-Py is a Python client for the Docker container
@@ -95,7 +92,7 @@ management tool.")
"1kjn64wx23jmr8dcc6g7bwlmrhfmxr77gh6iphqsl39sayfxdab9"))))
(build-system python-build-system)
(native-inputs
- `(("python-six" ,python-six)))
+ (list python-six))
(home-page "https://github.com/d11wtq/dockerpty")
(synopsis "Python library to use the pseudo-TTY of a Docker container")
(description "Docker PTY provides the functionality needed to operate the
@@ -118,18 +115,18 @@ client.")
;; TODO: Tests require running Docker daemon.
(arguments '(#:tests? #f))
(inputs
- `(("python-cached-property" ,python-cached-property)
- ("python-distro" ,python-distro)
- ("python-docker" ,python-docker)
- ("python-dockerpty" ,python-dockerpty)
- ("python-docopt" ,python-docopt)
- ("python-dotenv" ,python-dotenv)
- ("python-jsonschema" ,python-jsonschema)
- ("python-pyyaml" ,python-pyyaml)
- ("python-requests" ,python-requests)
- ("python-six" ,python-six)
- ("python-texttable" ,python-texttable)
- ("python-websocket-client" ,python-websocket-client)))
+ (list python-cached-property
+ python-distro
+ python-docker
+ python-dockerpty
+ python-docopt
+ python-dotenv
+ python-jsonschema
+ python-pyyaml
+ python-requests
+ python-six
+ python-texttable
+ python-websocket-client))
(home-page "https://www.docker.com/")
(synopsis "Multi-container orchestration for Docker")
(description "Docker Compose is a tool for defining and running
@@ -161,11 +158,9 @@ created and all the services are started as specified in the configuration.")
(("2.4.1") ,(package-version python-flake8)))
#t)))))
(native-inputs
- `(("python-flake8" ,python-flake8)
- ("python-pytest" ,python-pytest)
- ("python-pytest-cov" ,python-pytest-cov)))
+ (list python-flake8 python-pytest python-pytest-cov))
(propagated-inputs
- `(("python-six" ,python-six)))
+ (list python-six))
(home-page "https://github.com/shin-/dockerpy-creds")
(synopsis
"Python bindings for the Docker credentials store API")
@@ -233,14 +228,9 @@ Python without keeping their credentials in a Docker configuration file.")
(apply invoke "make" (string-append "DESTDIR=" out) "install"
',make-flags)))))))))
(inputs
- `(("btrfs-progs" ,btrfs-progs)
- ("libseccomp" ,libseccomp)
- ("pigz" ,pigz)
- ("runc" ,runc)
- ("util-linux" ,util-linux)))
+ (list btrfs-progs libseccomp pigz runc util-linux))
(native-inputs
- `(("go" ,go)
- ("pkg-config" ,pkg-config)))
+ (list go pkg-config))
(synopsis "Docker container runtime")
(description "This package provides the container daemon for Docker.
It includes image transfer and storage, container execution and supervision,
@@ -594,10 +584,8 @@ built-in registry server of Docker.")
("xfsprogs" ,xfsprogs)
("xz" ,xz)))
(native-inputs
- `(("eudev" ,eudev) ; TODO: Should be propagated by lvm2 (.pc -> .pc)
- ("go" ,go)
- ("gotestsum" ,gotestsum)
- ("pkg-config" ,pkg-config)))
+ (list eudev ; TODO: Should be propagated by lvm2 (.pc -> .pc)
+ go gotestsum pkg-config))
(synopsis "Docker container component library, and daemon")
(description "This package provides a framework to assemble specialized
container systems. It includes components for orchestration, image
@@ -668,9 +656,7 @@ provisioning etc.")
(install-file "build/docker" out-bin)
#t))))))
(native-inputs
- `(("go" ,go)
- ("libltdl" ,libltdl)
- ("pkg-config" ,pkg-config)))
+ (list go libltdl pkg-config))
(synopsis "Command line interface to Docker")
(description "This package provides a command line interface to Docker.")
(home-page "https://www.docker.com/")