summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-15 22:03:52 +0200
committerMarius Bakke <marius@gnu.org>2020-11-21 01:21:31 +0100
commit2920e8841341909ff570f8544e14e35fabbf8556 (patch)
tree4c17359daa54cc426c6ddbaba91fccce475eb856 /gnu/packages/docker.scm
parent48d8176e006a6e7460b81c2386119181cf360ca5 (diff)
downloadguix-patches-2920e8841341909ff570f8544e14e35fabbf8556.tar
guix-patches-2920e8841341909ff570f8544e14e35fabbf8556.tar.gz
gnu: python-docker: Propagate runtime dependency.
* gnu/packages/docker.scm (python-docker)[inputs]: Move PYTHON-WEBSOCKET-CLIENT from here ... [propagated-inputs]: ... to here.
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index c08f6eb3c6..950986045e 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -70,11 +70,11 @@
(inputs
`(("python-requests" ,python-requests-2.20)
("python-six" ,python-six)
- ("python-urllib3" ,python-urllib3-1.24)
- ("python-websocket-client" ,python-websocket-client)))
+ ("python-urllib3" ,python-urllib3-1.24)))
(propagated-inputs
`(("python-docker-pycreds" ,python-docker-pycreds)
- ("python-paramiko" ,python-paramiko))) ; adds SSH support
+ ("python-paramiko" ,python-paramiko) ;adds SSH support
+ ("python-websocket-client" ,python-websocket-client)))
(home-page "https://github.com/docker/docker-py/")
(synopsis "Python client for Docker")
(description "Docker-Py is a Python client for the Docker container