summaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-04-11 22:57:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-05 21:21:01 -0400
commit079f0eb3d22ce087a811e7f1ab0b0a6042edd209 (patch)
tree137565d8db8ef6c3293c0f69bf74bd48000b70bc /gnu/packages/docker.scm
parent3f280d3950f60da8f04f0dc5e767bcddc4749523 (diff)
downloadguix-patches-079f0eb3d22ce087a811e7f1ab0b0a6042edd209.tar
guix-patches-079f0eb3d22ce087a811e7f1ab0b0a6042edd209.tar.gz
gnu: docker: Make macros use a relative path as argument.
* gnu/packages/docker.scm (docker)[phases]: Move implementation detail inside the SUBSTITUTE-LOOKPATH and SUBSTITUTE-COMMAND macros definition, so that the relative path argument can be given as a relative path.
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm56
1 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 847871a95f..e8a742bfe1 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -378,7 +378,7 @@ built-in registry server of Docker.")
"\")"))
(string-append "\""
(assoc-ref inputs package)
- relative-path
+ "/" relative-path
"\", error(nil)")))))))
(substitute-Command
(lambda (x)
@@ -393,29 +393,29 @@ built-in registry server of Docker.")
(string-append (if re? re? "")
"exec.Command(\""
(assoc-ref inputs package)
- relative-path
+ "/" relative-path
"\""))))))))
- (substitute-LookPath "ps" "procps" "/bin/ps")
- (substitute-LookPath "mkfs.xfs" "xfsprogs" "/bin/mkfs.xfs")
- (substitute-LookPath "lvmdiskscan" "lvm2" "/sbin/lvmdiskscan")
- (substitute-LookPath "pvdisplay" "lvm2" "/sbin/pvdisplay")
- (substitute-LookPath "blkid" "util-linux" "/sbin/blkid")
- (substitute-LookPath "unpigz" "pigz" "/bin/unpigz")
- (substitute-LookPath "iptables" "iptables" "/sbin/iptables")
- (substitute-LookPath "iptables-legacy" "iptables" "/sbin/iptables")
- (substitute-LookPath "ip" "iproute2" "/sbin/ip")
- (substitute-Command "modprobe" "kmod" "/bin/modprobe")
- (substitute-Command "pvcreate" "lvm2" "/sbin/pvcreate")
- (substitute-Command "vgcreate" "lvm2" "/sbin/vgcreate")
- (substitute-Command "lvcreate" "lvm2" "/sbin/lvcreate")
- (substitute-Command "lvconvert" "lvm2" "/sbin/lvconvert")
- (substitute-Command "lvchange" "lvm2" "/sbin/lvchange")
- (substitute-Command "mkfs.xfs" "xfsprogs" "/sbin/mkfs.xfs")
- (substitute-Command "xfs_growfs" "xfsprogs" "/sbin/xfs_growfs")
- (substitute-Command "mkfs.ext4" "e2fsprogs" "/sbin/mkfs.ext4")
- (substitute-Command "tune2fs" "e2fsprogs" "/sbin/tune2fs")
- (substitute-Command "blkid" "util-linux" "/sbin/blkid")
- (substitute-Command "resize2fs" "e2fsprogs" "/sbin/resize2fs")
+ (substitute-LookPath "ps" "procps" "bin/ps")
+ (substitute-LookPath "mkfs.xfs" "xfsprogs" "bin/mkfs.xfs")
+ (substitute-LookPath "lvmdiskscan" "lvm2" "sbin/lvmdiskscan")
+ (substitute-LookPath "pvdisplay" "lvm2" "sbin/pvdisplay")
+ (substitute-LookPath "blkid" "util-linux" "sbin/blkid")
+ (substitute-LookPath "unpigz" "pigz" "bin/unpigz")
+ (substitute-LookPath "iptables" "iptables" "sbin/iptables")
+ (substitute-LookPath "iptables-legacy" "iptables" "sbin/iptables")
+ (substitute-LookPath "ip" "iproute2" "sbin/ip")
+ (substitute-Command "modprobe" "kmod" "bin/modprobe")
+ (substitute-Command "pvcreate" "lvm2" "sbin/pvcreate")
+ (substitute-Command "vgcreate" "lvm2" "sbin/vgcreate")
+ (substitute-Command "lvcreate" "lvm2" "sbin/lvcreate")
+ (substitute-Command "lvconvert" "lvm2" "sbin/lvconvert")
+ (substitute-Command "lvchange" "lvm2" "sbin/lvchange")
+ (substitute-Command "mkfs.xfs" "xfsprogs" "sbin/mkfs.xfs")
+ (substitute-Command "xfs_growfs" "xfsprogs" "sbin/xfs_growfs")
+ (substitute-Command "mkfs.ext4" "e2fsprogs" "sbin/mkfs.ext4")
+ (substitute-Command "tune2fs" "e2fsprogs" "sbin/tune2fs")
+ (substitute-Command "blkid" "util-linux" "sbin/blkid")
+ (substitute-Command "resize2fs" "e2fsprogs" "sbin/resize2fs")
;; docker-mountfrom ??
;; docker
;; docker-untar ??
@@ -423,11 +423,11 @@ built-in registry server of Docker.")
;; /usr/bin/uname
;; grep
;; apparmor_parser
- (substitute-Command "ps" "procps" "/bin/ps")
- (substitute-Command "losetup" "util-linux" "/sbin/losetup")
- (substitute-Command "uname" "coreutils" "/bin/uname")
- (substitute-Command "dbus-launch" "dbus" "/bin/dbus-launch")
- (substitute-Command "git" "git" "/bin/git"))
+ (substitute-Command "ps" "procps" "bin/ps")
+ (substitute-Command "losetup" "util-linux" "sbin/losetup")
+ (substitute-Command "uname" "coreutils" "bin/uname")
+ (substitute-Command "dbus-launch" "dbus" "bin/dbus-launch")
+ (substitute-Command "git" "git" "bin/git"))
;; Make compilation fail when, in future versions, Docker
;; invokes other programs we don't know about and thus don't
;; substitute.