summaryrefslogtreecommitdiff
path: root/gnu/packages/docbook.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-01 23:30:49 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-01 23:43:37 +0100
commit3cc0342b45406f97d675266cc9ac7877be855122 (patch)
treea00085f7a858b869ccd10a4438ff6d39ceaccd41 /gnu/packages/docbook.scm
parent463fb7d0c86fb9957c527272e6cec5ee23585366 (diff)
downloadguix-patches-3cc0342b45406f97d675266cc9ac7877be855122.tar
guix-patches-3cc0342b45406f97d675266cc9ac7877be855122.tar.gz
gnu: dblatex: Do not use python setuptools for building.
* gnu/packages/docbook.scm (dblatex)[arguments]: Set #:use-setuptools? to false.
Diffstat (limited to 'gnu/packages/docbook.scm')
-rw-r--r--gnu/packages/docbook.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 8efe417054..d0895772f7 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -192,6 +192,11 @@ by no means limited to these applications.) This package provides XML DTDs.")
("libxslt" ,libxslt))) ;for xsltproc
(arguments
`(#:python ,python-2 ;'print' syntax
+ ;; XXX: Disable usage of setuptools, even though it is supported.
+ ;; This causes an invalid "package_base" in out/bin/.dblatex-real
+ ;; due to a missing leading '/'. See this thread for details:
+ ;; https://lists.gnu.org/archive/html/guix-devel/2016-12/msg00030.html
+ #:use-setuptools? #f
#:tests? #f ;no 'test' command
#:phases
(alist-cons-after