summaryrefslogtreecommitdiff
path: root/gnu/packages/docbook.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-04-07 20:58:25 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-04-15 00:59:07 +0200
commit1e47d0e24520dcbfa15273244ea8d04c17118f8e (patch)
treee4dbd499b6e8a6e15df7af8f8a880b7cfcc5a316 /gnu/packages/docbook.scm
parentb0a6a9713076347c14ee2dd0ea494ab086df2a82 (diff)
downloadguix-patches-1e47d0e24520dcbfa15273244ea8d04c17118f8e.tar
guix-patches-1e47d0e24520dcbfa15273244ea8d04c17118f8e.tar.gz
gnu: Add docbook-xml-4.1.2.
* gnu/packages/docbook.scm (docbook-xml-4.1.2): New variable.
Diffstat (limited to 'gnu/packages/docbook.scm')
-rw-r--r--gnu/packages/docbook.scm30
1 files changed, 27 insertions, 3 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 9f5fbf1d96..2bd86fe5d2 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -74,7 +75,7 @@ by no means limited to these applications.) This package provides XML DTDs.")
(define-public docbook-xml-4.4
(package (inherit docbook-xml)
- (version "4.4")
+ (version "4.4")
(source (origin
(method url-fetch)
(uri (string-append "http://www.docbook.org/xml/" version
@@ -85,7 +86,7 @@ by no means limited to these applications.) This package provides XML DTDs.")
(define-public docbook-xml-4.3
(package (inherit docbook-xml)
- (version "4.3")
+ (version "4.3")
(source (origin
(method url-fetch)
(uri (string-append "http://www.docbook.org/xml/" version
@@ -96,7 +97,7 @@ by no means limited to these applications.) This package provides XML DTDs.")
(define-public docbook-xml-4.2
(package (inherit docbook-xml)
- (version "4.2")
+ (version "4.2")
(source (origin
(method url-fetch)
(uri (string-append "http://www.docbook.org/xml/" version
@@ -105,6 +106,29 @@ by no means limited to these applications.) This package provides XML DTDs.")
(base32
"18hgwvmywh6a5jh38szjmg3hg2r4v5lb6r3ydc3rd8cp9wg61i5c"))))))
+(define-public docbook-xml-4.1.2
+ (package (inherit docbook-xml)
+ (version "4.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.docbook.org/xml/" version
+ "/docbkx412.zip"))
+ (sha256
+ (base32
+ "0wkp5rvnqj0ghxia0558mnn4c7s3n501j99q2isp3sp0ci069w1h"))))
+ (arguments
+ '(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((source (assoc-ref %build-inputs "source"))
+ (unzip (string-append (assoc-ref %build-inputs "unzip")
+ "/bin/unzip"))
+ (dtd (string-append (assoc-ref %outputs "out")
+ "/xml/dtd/docbook")))
+ (mkdir-p dtd)
+ (zero? (system* unzip source "-d" dtd))))))))
+
(define-public docbook-xsl
(package
(name "docbook-xsl")