summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-04-09 17:17:55 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-04-09 17:18:43 +0200
commitc8d809f9a49c2b4ec5500c2685e96168dcd9afa9 (patch)
tree78b18fe0368e16a7ffc4db542b0b032d29ee557e /gnu/packages/dns.scm
parentc3c338e0b56bfe936f29adc3af89ffea35e72ced (diff)
downloadguix-patches-c8d809f9a49c2b4ec5500c2685e96168dcd9afa9.tar
guix-patches-c8d809f9a49c2b4ec5500c2685e96168dcd9afa9.tar.gz
gnu: dnsmasq: Update to 2.85 [fixes CVE-2021-3448].
* gnu/packages/dns.scm (dnsmasq): Update to 2.85.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index c940657ce9..3cf88febae 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -278,7 +278,7 @@ prompt the user with the option to go with insecure DNS only.")
(define-public dnsmasq
(package
(name "dnsmasq")
- (version "2.84")
+ (version "2.85")
(source (origin
(method url-fetch)
(uri (string-append
@@ -286,7 +286,7 @@ prompt the user with the option to go with insecure DNS only.")
version ".tar.xz"))
(sha256
(base32
- "0305a0c3snwqcv77sipyynr55xip1fp2843yn04pc4vk9g39acb0"))))
+ "1yhjwgz8g5qrqvxh6bbmg3443zi8qqjks3q872wyb1zn7n0d765d"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))