summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 22:42:11 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-05 01:36:22 +0200
commitbbf60f86d5b57ee085cd701ccf491c075f329de7 (patch)
treeccb677359291c88d97856343a40d1c38501ad76a /gnu/packages/dns.scm
parent9f55a39cf19dab41cfe7198b35a6c62a2270fb0d (diff)
downloadguix-patches-bbf60f86d5b57ee085cd701ccf491c075f329de7.tar
guix-patches-bbf60f86d5b57ee085cd701ccf491c075f329de7.tar.gz
gnu: Add rbldnsd.
* gnu/packages/dns.scm (rbldnsd): New public variable.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 27bc01ff82..6620c6b1d9 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -606,6 +606,60 @@ run in a @code{chroot} jail, thus making any security flaws in NSD less likely
to result in system-wide compromise.")
(license (list license:bsd-3))))
+(define-public rbldnsd
+ (package
+ (name "rbldnsd")
+ (version "0.998b")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spamhaus/rbldnsd")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jj3kyir43qnjgd9rk0wz13iggf3p4p1779v0wgmx3ci0ypnglcr"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ ;; The ./configure is hand-written and doesn't ignore unknown
+ ;; standard autotools options like CONFIG_SHELL.
+ (lambda _
+ (invoke "./configure")))
+ (replace 'install
+ ;; There is no Makefile ‘install’ target. contrib/debian/rules has
+ ;; one but relies on Debian-specific helpers, so install manually.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (sbin (string-append out "/sbin"))
+ (man8 (string-append out "/share/man/man8")))
+ (install-file "rbldnsd" sbin)
+ (install-file "rbldnsd.8" man8)))))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (native-inputs
+ ;; For running the test suite. Python 3 is not yet supported by a release:
+ ;; see <https://github.com/spamhaus/rbldnsd/issues/16>.
+ `(("python" ,python-2)))
+ (home-page "https://rbldnsd.io/")
+ (synopsis
+ "Small nameserver to efficiently serve @acronym{DNSBL, DNS blocklists}")
+ (description
+ "This package contains a small DNS daemon especially made to handle queries
+of @acronym{DNSBL, DNS blocklists}, a simple way to publish IP addresses and/or
+(domain) names which are somehow notable. Such lists are frequently used to
+refuse e-mail service to clients known to send unwanted (spam) messages.
+
+@command{rbldnsd} is not a general-purpose nameserver. It answers to a limited
+variety of queries. This makes it extremely fast---greatly outperforming both
+BIND and djbdns---whilst using relatively little memory.")
+ (license
+ (list license:bsd-3 ; btrie.[ch]
+ license:lgpl2.1+ ; qsort.c
+ license:gpl2+)))) ; the rest
+
(define-public unbound
(package
(name "unbound")