summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-14 21:35:14 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-15 19:11:13 +0100
commitb9d020056d7e5a63d1c0f81c513bfd73c790390e (patch)
tree3cdbbcc3a3bb921465cbb66dab4e8ae7b29a62b8 /gnu/packages/dns.scm
parent20ecede9690cb7f75bc8fee60619a4adf82ba4d5 (diff)
downloadguix-patches-b9d020056d7e5a63d1c0f81c513bfd73c790390e.tar
guix-patches-b9d020056d7e5a63d1c0f81c513bfd73c790390e.tar.gz
gnu: bind: Use INVOKE.
* gnu/packages/dns.scm (isc-bind)[arguments]: Substitute INVOKE for SYSTEM* and end phase with an explicit #t.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 08304b0c4c..d093b0d9b5 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -149,7 +149,8 @@ and BOOTP/TFTP for network booting of diskless machines.")
;; (system "bin/tests/system/ifconfig.sh up")))
(replace 'check
(lambda _
- (zero? (system* "make" "force-test")))))))
+ (invoke "make" "force-test")
+ #t)))))
(synopsis "An implementation of the Domain Name System")
(description "BIND is an implementation of the @dfn{Domain Name System}
(DNS) protocols for the Internet. It is a reference implementation of those