summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-17 21:10:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-17 22:51:56 +0100
commit8d973a5a9b7f6469c9af4d877479417e9d4d7a8f (patch)
tree12b1b81fc199e74c20c5e863f5ae74ee91a90477 /gnu/packages/dns.scm
parentad1cd31155d11957f4acfbf9ceea00f7fab318f4 (diff)
downloadguix-patches-8d973a5a9b7f6469c9af4d877479417e9d4d7a8f.tar
guix-patches-8d973a5a9b7f6469c9af4d877479417e9d4d7a8f.tar.gz
gnu: knot-resolver: Update to 5.4.3.
* gnu/packages/dns.scm (knot-resolver): Update to 5.4.3. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index b52c998184..5c5f95537b 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -1045,14 +1045,14 @@ synthesis, and on-the-fly re-configuration.")
(define-public knot-resolver
(package
(name "knot-resolver")
- (version "5.4.2")
+ (version "5.4.3")
(source (origin
(method url-fetch)
(uri (string-append "https://secure.nic.cz/files/knot-resolver/"
"knot-resolver-" version ".tar.xz"))
(sha256
(base32
- "12x5cd09rv530pak5f2smxcfq2zdqg0g5qxsd5k0alm7f6aj2spa"))))
+ "01m5s2kllr0apkg0bcfagzvijyfbivby03d1pjv3c0qrjgmjk1s8"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
@@ -1064,8 +1064,7 @@ synthesis, and on-the-fly re-configuration.")
;; Disable the default managed root TA, since we don't have
;; write access to the keyfile and its directory in store.
(substitute* "daemon/lua/sandbox.lua.in"
- (("^trust_anchors\\.add_file.*") ""))
- #t))
+ (("^trust_anchors\\.add_file.*") ""))))
(add-after 'build 'build-doc
(lambda _
(invoke "ninja" "doc")))
@@ -1096,8 +1095,7 @@ synthesis, and on-the-fly re-configuration.")
(string-append p "/lib/lua/5.1/?.so"))))
(wrap-program (string-append out "/sbin/kresd")
`("LUA_PATH" ";" prefix ,(map lua-path lua-*))
- `("LUA_CPATH" ";" prefix ,(map lua-cpath lua-*)))
- #t))))))
+ `("LUA_CPATH" ";" prefix ,(map lua-cpath lua-*)))))))))
(native-inputs
(list cmocka ; for unit tests
doxygen