summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/dns.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm124
1 files changed, 52 insertions, 72 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 63bf66647c..dae3b27ee2 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -127,10 +127,7 @@
":"))))
#t)))))
(inputs
- `(("bash-minimal" ,bash-minimal)
- ("curl" ,curl)
- ("grep" ,grep)
- ("json.sh" ,json.sh)))
+ (list bash-minimal curl grep json.sh))
(synopsis
"CLI to edit Cloudflare DNS records")
(description
@@ -213,9 +210,7 @@ protocol.")
("python" ,python-wrapper)
("swig" ,swig)))
(inputs
- `(("libpcap" ,libpcap)
- ("nss-certs" ,nss-certs)
- ("openssl" ,openssl)))
+ (list libpcap nss-certs openssl))
(synopsis "DNS library that facilitates DNS tool programming")
(description "LDNS aims to simplify DNS programming, it supports recent
RFCs like the DNSSEC documents, and allows developers to easily create
@@ -342,9 +337,9 @@ prompt the user with the option to go with insecure DNS only.")
"027b0ycw8h8yvvkq46vnr7dv8iqn5srm4kr7hm7sq110kvy2rm98"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("dbus" ,dbus)))
+ (list dbus))
(arguments
`(#:phases
(modify-phases %standard-phases (delete 'configure))
@@ -388,16 +383,15 @@ and BOOTP/TFTP for network booting of diskless machines.")
(outputs `("out" "utils"))
(inputs
;; It would be nice to add GeoIP and gssapi once there are packages.
- `(("libcap" ,libcap)
- ("libuv" ,libuv)
- ("libxml2" ,libxml2)
- ("openssl" ,openssl)
- ("p11-kit" ,p11-kit)
- ("python" ,python)
- ("python-ply" ,python-ply)))
+ (list libcap
+ libuv
+ libxml2
+ openssl
+ p11-kit
+ python
+ python-ply))
(native-inputs
- `(("perl" ,perl)
- ("pkg-config" ,pkg-config)))
+ (list perl pkg-config))
(arguments
`(#:configure-flags
(list (string-append "--with-pkcs11="
@@ -490,13 +484,9 @@ Dynamic DNS update utility
;; The system version is still favored and referenced.
(invoke "autoreconf" "-vif"))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("automake" ,automake)
- ("autoconf" ,autoconf)
- ("libtool" ,libtool)))
+ (list pkg-config automake autoconf libtool))
(inputs
- `(("libltdl" ,libltdl)
- ("libsodium" ,libsodium)))
+ (list libltdl libsodium))
(home-page "https://www.dnscrypt.org/")
(synopsis "Securely send DNS requests to a remote server")
(description
@@ -535,10 +525,9 @@ servers is included, and an up-to-date version is available at
(lambda _
(invoke "make" "configure"))))))
(native-inputs
- `(("autoconf" ,autoconf)))
+ (list autoconf))
(inputs
- `(("libevent" ,libevent)
- ("libsodium" ,libsodium)))
+ (list libevent libsodium))
(home-page "https://github.com/Cofyc/dnscrypt-wrapper")
(synopsis "Server-side dnscrypt proxy")
(description
@@ -575,10 +564,7 @@ the two.")
(string-append out "/share/man/man3"))
#t))))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ (list autoconf automake libtool pkg-config))
(home-page "https://www.opensmtpd.org")
(synopsis "Asynchronous resolver library by the OpenBSD project")
(description
@@ -640,8 +626,7 @@ asynchronous fashion.")
(string-append doc "/examples/" file-name)))))))
#:tests? #f)) ; no tests
(inputs
- `(("libevent" ,libevent)
- ("openssl" ,openssl)))
+ (list libevent openssl))
(home-page "https://www.nlnetlabs.nl/projects/nsd/about/")
(synopsis "Authoritative DNS name server")
(description "@dfn{NSD}, short for Name Server Daemon, is an authoritative
@@ -692,7 +677,7 @@ to result in system-wide compromise.")
(install-file "rbldnsd" sbin)
(install-file "rbldnsd.8" man8)))))))
(inputs
- `(("zlib" ,zlib)))
+ (list zlib))
(native-inputs
;; For running the test suite. Python 3 is not yet supported by a release:
;; see <https://github.com/spamhaus/rbldnsd/issues/16>.
@@ -728,15 +713,14 @@ BIND and djbdns---whilst using relatively little memory.")
(build-system gnu-build-system)
(outputs '("out" "python"))
(native-inputs
- `(("flex" ,flex)
- ("swig" ,swig)))
+ (list flex swig))
(inputs
- `(("expat" ,expat)
- ("libevent" ,libevent)
- ("nghttp2" ,nghttp2 "lib")
- ("protobuf" ,protobuf)
- ("python-wrapper" ,python-wrapper)
- ("openssl" ,openssl)))
+ (list expat
+ libevent
+ `(,nghttp2 "lib")
+ protobuf
+ python-wrapper
+ openssl))
(arguments
`(#:configure-flags
(list "--disable-static" ; save space and non-determinism in libunbound.a
@@ -889,9 +873,9 @@ served by AS112. Stub and forward zones are supported.")
(base32 "1mwy6sfnlaslx26f3kpj9alh8i8y8bf1nbnsdd5j04hjsbavd07p")))))
(build-system gnu-build-system)
(native-inputs
- `(("which" ,which)))
+ (list which))
(inputs
- `(("openssl" ,openssl)))
+ (list openssl))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1018,13 +1002,13 @@ Extensions} (DNSSEC).")
(rename-file (string-append out "/share/man/man1")
(string-append tools "/share/man/man1"))))))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("python-sphinx" ,python-sphinx)
- ("ragel" ,ragel)
- ("texinfo" ,texinfo)))
+ (list autoconf
+ automake
+ libtool
+ pkg-config
+ python-sphinx
+ ragel
+ texinfo))
(inputs
`(("fstrm" ,fstrm)
("gnutls" ,gnutls)
@@ -1115,14 +1099,14 @@ synthesis, and on-the-fly re-configuration.")
`("LUA_CPATH" ";" prefix ,(map lua-cpath lua-*)))
#t))))))
(native-inputs
- `(("cmocka" ,cmocka) ; for unit tests
- ("doxygen" ,doxygen)
- ("protobuf-c" ,protobuf-c)
- ("pkg-config" ,pkg-config)
- ("python-breathe" ,python-breathe)
- ("python-sphinx" ,python-sphinx)
- ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
- ("texinfo" ,texinfo)))
+ (list cmocka ; for unit tests
+ doxygen
+ protobuf-c
+ pkg-config
+ python-breathe
+ python-sphinx
+ python-sphinx-rtd-theme
+ texinfo))
(inputs
`(("fstrm" ,fstrm)
("gnutls" ,gnutls)
@@ -1159,14 +1143,13 @@ LuaJIT, both a resolver library and a daemon.")
(base32 "0hf377g4j9r9sac75xp17nk2h58mazswz4vkg4g2gl2yyhvzq91w"))))
(build-system trivial-build-system) ; no Makefile.PL
(native-inputs
- `(("bash" ,bash)
- ("perl" ,perl)))
+ (list bash perl))
(inputs
- `(("inetutils" ,inetutils) ; logger
- ("net-tools" ,net-tools)
- ("perl-data-validate-ip" ,perl-data-validate-ip)
- ("perl-digest-sha1" ,perl-digest-sha1)
- ("perl-io-socket-ssl" ,perl-io-socket-ssl)))
+ (list inetutils ; logger
+ net-tools
+ perl-data-validate-ip
+ perl-digest-sha1
+ perl-io-socket-ssl))
(arguments
`(#:modules ((guix build utils))
#:builder
@@ -1264,12 +1247,9 @@ attempts the update when it has changed.")
(arguments
'(#:configure-flags '("--disable-static"))) ;no need for libhsk.a
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
+ (list autoconf automake libtool))
(inputs
- `(("unbound" ,unbound)
- ("libuv" ,libuv)))
+ (list unbound libuv))
(home-page "https://www.handshake.org/")
(synopsis "Resolver daemon for the Handshake naming protocol")
(description
@@ -1431,7 +1411,7 @@ RESOLVCONF=\"$0\"
PATH=~a/bin:$PATH"
coreutils)))))))))
(inputs
- `(("coreutils-minimal" ,coreutils-minimal)))
+ (list coreutils-minimal))
(home-page "https://roy.marples.name/projects/openresolv/")
(synopsis "Resolvconf POSIX compliant implementation, a middleman for resolv.conf")
(description "openresolv is an implementation of @command{resolvconf}, the