summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 21:46:15 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 21:49:54 +0200
commit7f5e881e3181153c0830aa09807931ff5c51662d (patch)
tree8c34c4b14834782ff9c3829b2ddb51bd4b0d533c /gnu/packages/dns.scm
parentfdb4540f7814ca95617d8cb65ccd814135bb0b85 (diff)
downloadguix-patches-7f5e881e3181153c0830aa09807931ff5c51662d.tar
guix-patches-7f5e881e3181153c0830aa09807931ff5c51662d.tar.gz
gnu: knot: Honour PARALLEL-BUILD?.
* gnu/packages/dns.scm (knot)[arguments]: Spawn multiple make jobs if requested.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm27
1 files changed, 19 insertions, 8 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index b5fffc35d0..9a1737f328 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -870,19 +870,30 @@ Extensions} (DNSSEC).")
;; This is needed even when using ‘make config_dir=... install’.
(substitute* "src/Makefile.in" (("\\$\\(INSTALL\\) -d") "true"))))
(add-after 'build 'build-info
- (lambda _
- (invoke "make" "info")))
+ (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
+ (apply invoke "make" "info"
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags))))
(replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key make-flags outputs parallel-build? #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(doc (string-append out "/share/doc/" ,name "-" ,version))
(etc (string-append doc "/examples/etc")))
- (invoke "make"
- (string-append "config_dir=" etc)
- "install"))))
+ (apply invoke "make" "install"
+ (string-append "config_dir=" etc)
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags)))))
(add-after 'install 'install-info
- (lambda _
- (invoke "make" "install-info")))
+ (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
+ (apply invoke "make" "install-info"
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags))))
(add-after 'install 'break-circular-:lib->:out-reference
(lambda* (#:key outputs #:allow-other-keys)
(let ((lib (assoc-ref outputs "lib")))