summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-04-29 13:57:00 +0200
committerBrice Waegeneire <brice@waegenei.re>2020-05-13 11:25:37 +0200
commit6b6647f815457e93b55ee4a243345c1a1005ddc1 (patch)
tree4c9961482011b63265733c356b7a5b06f798c38e /gnu/packages/dns.scm
parent15014dc61858e14e3356c7489cd366555085048b (diff)
downloadguix-patches-6b6647f815457e93b55ee4a243345c1a1005ddc1.tar
guix-patches-6b6647f815457e93b55ee4a243345c1a1005ddc1.tar.gz
gnu: Add openresolv.
* gnu/packages/dns.scm (openresolv): New variable.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index e7c739f1a7..469ef7605d 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1001,3 +1002,34 @@ known public suffixes.")
consists of a UDP-only authoritative DNS server for hosting domains, and a UDP
and TCP-capable recursive DNS server for finding domains on the internet.")
(license license:bsd-2)))
+
+(define-public openresolv
+ (package
+ (name "openresolv")
+ (version "3.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://roy.marples.name/downloads/openresolv/"
+ "openresolv-" version ".tar.xz"))
+ (sha256
+ (base32
+ "01ms6c087la4hk0f0w6n2vpsb7dg4kklah2rqyhz88p0vr9bqy20"))
+ (patches
+ (search-patches "openresolv-restartcmd-guix.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No test suite
+ #:configure-flags
+ (list (string-append "--sysconfdir=/etc"))
+ #:make-flags
+ (list (string-append "SYSCONFDIR=/" (assoc-ref %outputs "out") "/etc"))))
+ (home-page "https://roy.marples.name/projects/openresolv/")
+ (synopsis "Resolvconf POSIX compliant implementation, a middleman for resolv.conf")
+ (description "openresolv is an implementation of @command{resolvconf}, the
+middleman between the network configuration services and
+@file{/etc/resolv.conf}. @command{resolvconf} itself is just a script that
+stores, removes and lists a full @file{resolv.conf} generated for the
+interface. It then calls all the helper scripts it knows about so it can
+configure the real @file{/etc/resolv.conf} and optionally any local
+nameservers other than libc.")
+ (license license:bsd-2)))