summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-22 13:59:21 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-23 00:11:09 +0100
commit6023ecab579f75384abe8a5772de24b5e1e85ae1 (patch)
tree9bd4931f3738ef9146f1b1d444e3d1fd1cce8f06 /gnu/packages/dns.scm
parentd349e6d9a8602ebb21433fb4db0f5a2f03afe78e (diff)
downloadguix-patches-6023ecab579f75384abe8a5772de24b5e1e85ae1.tar
guix-patches-6023ecab579f75384abe8a5772de24b5e1e85ae1.tar.gz
gnu: bind: Return #T from all phases.
* gnu/packages/dns.scm (isc-bind)[arguments]: Move #T from ‘check’ to ‘move-to-utils’ phase.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 034fe6916a..461d9f8c0c 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -146,7 +146,8 @@ and BOOTP/TFTP for network booting of diskless machines.")
"/share/man/man1/dig.1"
"/share/man/man1/host.1"
"/share/man/man1/nslookup.1"
- "/share/man/man1/nsupdate.1"))))
+ "/share/man/man1/nsupdate.1"))
+ #t))
;; When and if guix provides user namespaces for the build process,
;; then the following can be uncommented and the subsequent "force-test"
;; will not be necessary.
@@ -156,8 +157,7 @@ and BOOTP/TFTP for network booting of diskless machines.")
;; (system "bin/tests/system/ifconfig.sh up")))
(replace 'check
(lambda _
- (invoke "make" "force-test")
- #t)))))
+ (invoke "make" "force-test"))))))
(synopsis "An implementation of the Domain Name System")
(description "BIND is an implementation of the @dfn{Domain Name System}
(DNS) protocols for the Internet. It is a reference implementation of those