summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-12-23 23:52:27 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2016-12-23 23:54:15 +0100
commit4d2fd1c016c1ffeb613692949c9557083f946c82 (patch)
treee9b787d8103e3571749e123060ac46d225b3bdd9 /gnu/packages/dns.scm
parent8769d482ef2dc1863cb50761bbfb39f48607c2e3 (diff)
downloadguix-patches-4d2fd1c016c1ffeb613692949c9557083f946c82.tar
guix-patches-4d2fd1c016c1ffeb613692949c9557083f946c82.tar.gz
gnu: yadifa: Explicitly enable DNSSEC & caching.
* gnu/packages/dns.scm (yadifa)[arguments]: Add configure flags to consistently enable the ‘nsec’, ‘nsec3’, ‘tsig’, and ‘caching’ features.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 175864f519..55cfc02e95 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -285,6 +285,8 @@ asynchronous fashion.")
#:configure-flags (list "--sysconfdir=/etc" "--localstatedir=/var"
"--enable-shared" "--disable-static"
"--enable-messages" "--enable-ctrl"
+ "--enable-nsec" "--enable-nsec3"
+ "--enable-tsig" "--enable-caching"
;; NSID is a rarely-used debugging aid, that also
;; causes the build to fail. Just disable it.
"--disable-nsid")))