summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-01-02 19:28:18 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-01-03 20:38:16 +0100
commit498911d31597ae96882092998ac32e7986d85ae9 (patch)
tree4b1593a2db60587000c1c8a8fc491229d2d4394d /gnu/packages/dns.scm
parent4382cef28cb6de4b2b505788b759b0fe4f8ea603 (diff)
downloadguix-patches-498911d31597ae96882092998ac32e7986d85ae9.tar
guix-patches-498911d31597ae96882092998ac32e7986d85ae9.tar.gz
gnu: Add libmicrodns.
* gnu/packages/dns.scm (libmicrodns): New package.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index c7b630364d..2ebc3d8dad 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -781,3 +782,30 @@ attempts the update when it has changed.")
"@command{hnsd} is a @dfn{host name resolver} for the Handshake Naming
System (HNS) peer-to-peer network.")
(license license:expat))))
+
+(define-public libmicrodns
+ (package
+ (name "libmicrodns")
+ (version "0.0.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/videolabs/libmicrodns")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xvl9k49ng35wbsqmnjnyqvkyjf8dcq2ywsq3jp3wh0rgmxhq2fh"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "https://github.com/videolabs/libmicrodns")
+ (synopsis "Minimal mDNS resolver library")
+ (description "@code{libmicrodns} provides a minimal implementation of a
+mDNS resolver as well as an announcer. mDNS (Multicast Domain Name System) is
+a zero-config service that allows one to resolve host names to IP addresses in
+local networks.")
+ (license license:lgpl2.1)))