summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-14 23:53:58 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-15 14:31:22 +0100
commit47b8608d99a48bf169252875f88ab1d9f1022db0 (patch)
tree53c13a7321b9cd022d3aff3c3b2aaf3d8d5371f0 /gnu/packages/dns.scm
parent2c97c980a0ca5f77464cd74207e29d835376f85b (diff)
downloadguix-patches-47b8608d99a48bf169252875f88ab1d9f1022db0.tar
guix-patches-47b8608d99a48bf169252875f88ab1d9f1022db0.tar.gz
gnu: unbound: Update to 1.9.5 [fixes CVE-2019-18934].
The Guix unbound package is not vulnerable in its default configuration, because we do not build with ‘--enable-ipsecmod’. * gnu/packages/dns.scm (unbound): Update to 1.9.5.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 60e392de0d..e5148d5bc9 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 ng0 <ng0@n0.is>
-;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
@@ -390,14 +390,14 @@ to result in system-wide compromise.")
(define-public unbound
(package
(name "unbound")
- (version "1.9.4")
+ (version "1.9.5")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.unbound.net/downloads/unbound-"
version ".tar.gz"))
(sha256
- (base32 "1c2bjm13x8bkw0ds1mhn9ivd2gzmfrb0x5y76bkz09a04bxjagix"))))
+ (base32 "0myv8l886gmlh9nh4j3q5549idxnl51hf9cw20yxfqbwd47l13ca"))))
(build-system gnu-build-system)
(outputs '("out" "python"))
(native-inputs