summaryrefslogtreecommitdiff
path: root/gnu/packages/dlang.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/dlang.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/dlang.scm')
-rw-r--r--gnu/packages/dlang.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index c4cf1d9665..403fcbbd6b 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -75,7 +75,7 @@
(let ((bin (string-append (assoc-ref outputs "out") "/bin")))
(install-file "rdmd" bin)))))))
(native-inputs
- `(("ldc" ,ldc)))
+ (list ldc))
(home-page "https://github.com/D-Programming-Language/tools/")
(synopsis "Specialized equivalent to 'make' for the D language")
(description
@@ -448,9 +448,9 @@ integration tests...\n")
(install-file "bin/dub" bin)
#t))))))
(inputs
- `(("curl" ,curl)))
+ (list curl))
(native-inputs
- `(("ldc" ,ldc)))
+ (list ldc))
(home-page "https://code.dlang.org/getting_started")
(synopsis "Package and build manager for D projects")
(description