summaryrefslogtreecommitdiff
path: root/gnu/packages/dlang.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-21 17:04:32 +0200
committerRoel Janssen <roel@gnu.org>2021-05-21 18:05:07 +0200
commit082988afac8ddac7525b40fb7ef8da7ff40f8ad3 (patch)
tree22c71a537ff2dd15733562e7821233d55138a21c /gnu/packages/dlang.scm
parent97c2e9e4f8a6fe688912057b10a8def0eb61c570 (diff)
downloadguix-patches-082988afac8ddac7525b40fb7ef8da7ff40f8ad3.tar
guix-patches-082988afac8ddac7525b40fb7ef8da7ff40f8ad3.tar.gz
gnu: Fix build for ldc.
* gnu/packages/dlang.scm (ldc): Disable tests that use ptrace.
Diffstat (limited to 'gnu/packages/dlang.scm')
-rw-r--r--gnu/packages/dlang.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index da3b818c26..88a0887a0a 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -240,6 +240,17 @@ bootstrapping more recent compilers written in D.")
(delete-file "tests/compilable/ctfe_math.d")
(delete-file "tests/debuginfo/nested_gdb.d")
(delete-file "tests/debuginfo/classtypes_gdb.d")
+ ;; for the following tests ptrace fails with EPERM
+ ;; (see <https://issues.guix.gnu.org/48541>):
+ (delete-file "tests/d2/dmd-testsuite/runnable/b18504.d")
+ (delete-file "tests/d2/dmd-testsuite/runnable/gdb14225.d")
+ (delete-file "tests/d2/dmd-testsuite/runnable/gdb14276.d")
+ (delete-file "tests/d2/dmd-testsuite/runnable/gdb14313.d")
+ (delete-file "tests/d2/dmd-testsuite/runnable/gdb14330.d")
+ (delete-file "tests/d2/dmd-testsuite/runnable/gdb1.d")
+ (delete-file "tests/d2/dmd-testsuite/runnable/gdb4149.d")
+ (delete-file "tests/d2/dmd-testsuite/runnable/gdb4181.d")
+ (delete-file "tests/d2/dmd-testsuite/runnable/gdb15729.sh")
;; the following tests plugins we don't have.
(delete-file "tests/plugins/addFuncEntryCall/testPlugin.d")
;; the following tests requires AVX instruction set in the CPU.