summaryrefslogtreecommitdiff
path: root/gnu/packages/djvu.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/djvu.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/djvu.scm')
-rw-r--r--gnu/packages/djvu.scm48
1 files changed, 15 insertions, 33 deletions
diff --git a/gnu/packages/djvu.scm b/gnu/packages/djvu.scm
index a4cd4da2ed..07c77f318e 100644
--- a/gnu/packages/djvu.scm
+++ b/gnu/packages/djvu.scm
@@ -71,13 +71,9 @@
(build-system gnu-build-system)
(native-inputs
;; The 3.5.28 release tarball isn't bootstrapped.
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
+ (list autoconf automake libtool))
(inputs
- `(("libjpeg-turbo" ,libjpeg-turbo)
- ("libtiff" ,libtiff)
- ("zlib" ,zlib)))
+ (list libjpeg-turbo libtiff zlib))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -109,17 +105,9 @@ utilities.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("qttools" ,qttools)))
+ (list autoconf automake libtool pkg-config qttools))
(inputs
- `(("djvulibre" ,djvulibre)
- ("glib" ,glib)
- ("libxt" ,libxt)
- ("libtiff" ,libtiff)
- ("qtbase" ,qtbase-5)))
+ (list djvulibre glib libxt libtiff qtbase-5))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -213,12 +201,12 @@ It is able to extract:
(base32 "0v2ax30m7j1yi4m02nzn9rc4sn4vzqh5vywdh96r64j4pwvn5s5g"))))
(build-system gnu-build-system)
(inputs
- `(("djvulibre" ,djvulibre)
- ("gawk" ,gawk)
- ("ghostscript" ,ghostscript)
- ("grep" ,grep)
- ("ncurses" ,ncurses)
- ("which" ,which)))
+ (list djvulibre
+ gawk
+ ghostscript
+ grep
+ ncurses
+ which))
(arguments
`(#:tests? #f ; No test suite
#:phases
@@ -277,9 +265,7 @@ It is able to extract:
(native-inputs
`(("gettext" ,gettext-minimal)))
(inputs
- `(("libjpeg-turbo" ,libjpeg-turbo)
- ("libtiff" ,libtiff)
- ("zlib" ,zlib)))
+ (list libjpeg-turbo libtiff zlib))
(arguments
'(#:configure-flags '("--disable-static")
#:parallel-build? #f
@@ -318,10 +304,8 @@ and white.")
(base32 "0z403cklvxzz0qaczgv83ax0nknrd9h8micp04j9kjfdxk2sgval"))))
(build-system python-build-system)
(inputs
- `(("djvulibre" ,djvulibre)
- ("python2-djvulibre" ,python2-djvulibre)
- ("python2-subprocess32" ,python2-subprocess32)
- ("python2-wxpython" ,python2-wxpython)))
+ (list djvulibre python2-djvulibre python2-subprocess32
+ python2-wxpython))
(arguments
`(#:python ,python-2
#:phases
@@ -360,7 +344,7 @@ It is able to:
(base32 "0xyrnk8d2khi7q1zr28gjkjq6frz4mkb5jdl8821yzf12k7c8pbv"))))
(build-system gnu-build-system)
(native-inputs
- `(("python2-nose" ,python2-nose)))
+ (list python2-nose))
(inputs
`(("djvulibre" ,djvulibre)
("minidjvu" ,minidjvu)
@@ -427,9 +411,7 @@ and background layers of images, which can then be encoded into a DjVu file.")
(base32 "09w9rqr7z2jd5kwp178zz2yrsc82mxs7gksipg92znxzgzhmw2ng"))))
(build-system gnu-build-system)
(native-inputs
- `(("libxml2" ,libxml2)
- ("python2-nose" ,python2-nose)
- ("python2-pillow" ,python2-pillow)))
+ (list libxml2 python2-nose python2-pillow))
(inputs
`(("djvulibre" ,djvulibre)
("ocrad" ,ocrad)