summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-09-11 17:51:16 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-11 19:59:17 -0400
commitff64cba2cc5a029ade92644f99547f47ddf7d9c4 (patch)
tree3f7f30c80cbd06cb98d6743aaa0088dc4839cf3c /gnu/packages/django.scm
parent73f68c1a45bbdbd64633d5cc05f5dcf4080d581a (diff)
downloadguix-patches-ff64cba2cc5a029ade92644f99547f47ddf7d9c4.tar
guix-patches-ff64cba2cc5a029ade92644f99547f47ddf7d9c4.tar.gz
gnu: Add python-django-localflavor.
* gnu/packages/django.scm (python-django-localflavor): New variable. Co-authored-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index dd48e0553a..f8aae1e33f 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages databases)
#:use-module (gnu packages check)
+ #:use-module (gnu packages finance)
#:use-module (gnu packages geo)
#:use-module (gnu packages openldap)
#:use-module (gnu packages python)
@@ -194,6 +195,42 @@ to the @dfn{don't repeat yourself} (DRY) principle.")
commands, additional database fields and admin extensions.")
(license license:expat)))
+(define-public python-django-localflavor
+ (package
+ (name "python-django-localflavor")
+ (version "3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "django-localflavor" version))
+ (sha256
+ (base32 "0i1s0ijfd9rv2cp5x174jcyjpwn7fyg7s1wpbvlwm96bpdvs6bxc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (setenv "PYTHONPATH"
+ (string-append ".:"
+ (getenv "PYTHONPATH")))
+ (invoke "invoke" "test")))))))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-invoke" ,python-invoke)
+ ("python-pytest-django" ,python-pytest-django)
+ ("which" ,which)))
+ (propagated-inputs
+ `(("python-django" ,python-django)
+ ("python-stdnum" ,python-stdnum)))
+ (home-page "https://django-localflavor.readthedocs.io/en/latest/")
+ (synopsis "Country-specific Django helpers")
+ (description "Django-LocalFlavor is a collection of assorted pieces of code
+that are useful for particular countries or cultures.")
+ (license license:bsd-3)))
+
(define-public python-django-simple-math-captcha
(package
(name "python-django-simple-math-captcha")