summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorLuis Felipe <luis.felipe.la@protonmail.com>2021-12-02 15:48:05 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-05 21:44:51 +0100
commitf856c8f1b06d0c37accb88ffca39582d12c1ea07 (patch)
tree6066777fc175214703f5a8836eadccb2251acaa7 /gnu/packages/django.scm
parent648db3ad2bee9499bed1b7725eca2c2a4aaebe81 (diff)
downloadguix-patches-f856c8f1b06d0c37accb88ffca39582d12c1ea07.tar
guix-patches-f856c8f1b06d0c37accb88ffca39582d12c1ea07.tar.gz
gnu: Add python-django-svg-image-form-field.
* gnu/packages/django.scm (python-django-svg-image-form-field): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index d36950dc90..6598577149 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
;;; Copyright © 2019 Sam <smbaines8@gmail.com>
;;; Copyright © 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1357,3 +1358,28 @@ for filtering data. It allows the user to safely filter by model attributes
and also specify the lookup type for each filter (very much like
Django's filtering system in ORM).")
(license license:expat)))
+
+(define-public python-django-svg-image-form-field
+ (package
+ (name "python-django-svg-image-form-field")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artrey/django-svg-image-form-field")
+ (commit (string-append version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "131m545khn8l20j4x2bvlvz36dlbnhj9pc98i2dw72s3bw8pgws0"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-defusedxml" ,python-defusedxml)
+ ("python-django" ,python-django)
+ ("python-pillow" ,python-pillow)))
+ (home-page "https://github.com/artrey/django-svg-image-form-field")
+ (synopsis "Form field to validate SVG and other images")
+ (description "This form field allows users to provide SVG images for
+models that use Django's standard @code{ImageField}, in addition to the
+image files already supported by it.")
+ (license license:expat)))