summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-01 00:47:58 +0100
committerMarius Bakke <marius@gnu.org>2021-12-05 14:02:08 +0100
commite73f56544571a05bfa7cdaf79766d4985ed05247 (patch)
tree18ebd8507b2797dffa21342296c7b22add4158ae /gnu/packages/django.scm
parentddea9e32e74264226f9e8ba2601afab7c76e1e3f (diff)
downloadguix-patches-e73f56544571a05bfa7cdaf79766d4985ed05247.tar
guix-patches-e73f56544571a05bfa7cdaf79766d4985ed05247.tar.gz
gnu: python-django-sortedm2m: Fix tests.
This is a follow-up to commit 283d5ac97f2f7663b788bd2fc3b9a27a3d82c7d5. * gnu/packages/django.scm (python-django-sortedm2m): Invoke django-admin with pythonpath and test settings.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index b4ca3ab4ec..f30ec2c051 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -929,8 +929,9 @@ using Python multiprocessing.")
`(#:phases (modify-phases %standard-phases
(replace 'check
(lambda _
- (invoke "python" "django-admin.py"
- "test" "--settings=settings"))))))
+ (invoke "django-admin"
+ "test" "--settings=test_project.settings"
+ "--pythonpath=."))))))
(propagated-inputs
`(("python-django" ,python-django)))
(home-page "https://github.com/jazzband/django-sortedm2m")