summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-02-15 10:09:24 +0000
committerKei Kebreau <kei@openmailbox.org>2017-04-08 12:40:16 -0400
commite1f06e1192f57551bcb67d93411affb9d497e30c (patch)
treebf25c4e6bbd8dad09f90e024789525a451b973fc /gnu/packages/django.scm
parentccda56886625af84d34ebf1f26b22345e5dbe235 (diff)
downloadguix-patches-e1f06e1192f57551bcb67d93411affb9d497e30c.tar
guix-patches-e1f06e1192f57551bcb67d93411affb9d497e30c.tar.gz
gnu: Add python-django-allauth.
* gnu/packages/django.scm (python-django-allauth): New variable. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 805dca6c9e..4f7620ee27 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -189,3 +190,34 @@ them do this.")
(define-public python2-django-filter
(package-with-python2 python-django-filter))
+
+(define-public python-django-allauth
+ (package
+ (name "python-django-allauth")
+ (version "0.30.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "django-allauth" version))
+ (sha256
+ (base32
+ "1fslqc5qqb0b66yscvkyjwfv8cnbfx5nlkpnwimyb3pf1nc1w7r3"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-openid" ,python-openid)
+ ("python-requests" ,python-requests)
+ ("python-requests-oauthlib" ,python-requests-oauthlib)))
+ (native-inputs
+ `(("python-mock" ,python-mock)))
+ (inputs
+ `(("python-django" ,python-django)))
+ (home-page "https://github.com/pennersr/django-allauth")
+ (synopsis "Set of Django applications addressing authentication")
+ (description
+ "Integrated set of Django applications addressing authentication,
+registration, account management as well as 3rd party (social)
+account authentication.")
+ (license license:expat)))
+
+(define-public python2-django-allauth
+ (package-with-python2 python-django-allauth))