summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-01 14:42:16 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:57 +0200
commitdfbe9d2327c860e43b76ed369c8747412f7dfab3 (patch)
tree43c09f6fe0e4e478f32ad2d32e6bf829f133ce51 /gnu/packages/django.scm
parent7e244ac6639ec71010e699d74077e08c0ec4bc2f (diff)
downloadguix-patches-dfbe9d2327c860e43b76ed369c8747412f7dfab3.tar
guix-patches-dfbe9d2327c860e43b76ed369c8747412f7dfab3.tar.gz
gnu: python-django-statici18n: Update to 1.9.0.
* gnu/packages/django.scm (python-django-statici18n): Update to 1.9.0. [source]: Switch to GIT-FETCH. [arguments]: New field. [native-inputs]: Add PYTHON-PYTEST and PYTHON-PYTEST-DJANGO.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm25
1 files changed, 20 insertions, 5 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 285bb53596..059aec3107 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1042,18 +1042,33 @@ name is purely coincidental.")
(define-public python-django-statici18n
(package
(name "python-django-statici18n")
- (version "1.3.0")
+ (version "1.9.0")
+ (home-page "https://github.com/zyegfryed/django-statici18n")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "django-statici18n" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0alcf4g1nv69njhq5k3qw4mfl2k6dc18bik5nk0g1mnp3m8zyz7k"))))
+ "1p3myp2im6c87yc05alh91jyahqws5lcw3zzdsj4dh8lx9s9cgpf"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "PYTHONPATH"
+ (string-append "./tests/test_project:./build/lib:"
+ (getenv "PYTHONPATH")))
+ (setenv "DJANGO_SETTINGS_MODULE" "project.settings")
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-django" ,python-pytest-django)))
(propagated-inputs
`(("python-django" ,python-django)
("django-appconf" ,python-django-appconf)))
- (home-page "https://github.com/zyegfryed/django-statici18n")
(synopsis "Generate JavaScript catalog to static files")
(description
"A Django app that provides helper for generating JavaScript catalog to