summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 19:14:03 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:58:15 +0200
commitcb9b6095dc656948fb7d0391d7c3936e38074b95 (patch)
tree3ef1c518324bdf6f2fff3b2f4a24e6a59d8a8f72 /gnu/packages/django.scm
parentb939953b9a415d450dd8d3906114e67bf7ecad5c (diff)
downloadguix-patches-cb9b6095dc656948fb7d0391d7c3936e38074b95.tar
guix-patches-cb9b6095dc656948fb7d0391d7c3936e38074b95.tar.gz
gnu: Add python-django-rq.
* gnu/packages/django.scm (python-django-rq, python2-django-rq): New variables.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index eeccfcc2fa..de2d7db88b 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -509,3 +509,39 @@ project.")
(define-public python2-django-redis
(package-with-python2 python-django-redis))
+
+(define-public python-django-rq
+ (package
+ (name "python-django-rq")
+ (version "0.9.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "django-rq" version))
+ (sha256
+ (base32
+ "04v8ilfdp10bk31fxgh4cn083gsn5m06342cnpm5d10nd8hc0vky"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (and (zero? (system* "redis-server" "--daemonize" "yes"))
+ (zero? (system* "django-admin.py" "test" "django_rq"
+ "--settings=django_rq.test_settings"
+ "--pythonpath="))))))))
+ (native-inputs
+ `(("redis" ,redis)))
+ (propagated-inputs
+ `(("python-django" ,python-django)
+ ("python-rq" ,python-rq)))
+ (home-page "https://github.com/ui/django-rq")
+ (synopsis "Django integration with RQ")
+ (description
+ "Django integration with RQ, a Redis based Python queuing library.
+Django-RQ is a simple app that allows you to configure your queues in django's
+settings.py and easily use them in your project.")
+ (license license:expat)))
+
+(define-public python2-django-rq
+ (package-with-python2 python-django-rq))