summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-23 13:31:08 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:57:57 +0200
commitafbfe564977300133e3a48bdedb4cb37a57121d8 (patch)
tree0a527e9673a6c03a1f49c9629f0605a22535876a /gnu/packages/django.scm
parenta326384be44edf1bf1b081f21a7db2b904859f41 (diff)
downloadguix-patches-afbfe564977300133e3a48bdedb4cb37a57121d8.tar
guix-patches-afbfe564977300133e3a48bdedb4cb37a57121d8.tar.gz
gnu: Add python-django-bulk-update.
* gnu/packages/django.scm (python-django-bulk-update, python2-django-bulk-update): New variables.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 3477895d3d..6190c85330 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -347,3 +347,33 @@ conn_max_age argument to easily enable Django’s connection pool.")
(define-public python2-dj-database-url
(package-with-python2 python-dj-database-url))
+
+(define-public python-django-bulk-update
+ (package
+ (name "python-django-bulk-update")
+ (version "1.1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "django-bulk-update" version))
+ (sha256
+ (base32
+ "0mbng9m7swfc0dnidipbzlxfhlfjrv755dlnha5s4m9mgdxb1fhc"))))
+ (build-system python-build-system)
+ (arguments
+ ;; tests don't support django 1.10, but the module seems to work.
+ `(#:tests? #f))
+ (native-inputs
+ `(("six" ,python-six)
+ ("jsonfield" ,python-django-jsonfield)
+ ("python-dj-database-url" ,python-dj-database-url)))
+ (propagated-inputs
+ `(("python-django" ,python-django)))
+ (home-page "https://github.com/aykut/django-bulk-update")
+ (synopsis "Simple bulk update over Django ORM or with helper function")
+ (description
+ "Simple bulk update over Django ORM or with helper function. This
+project aims to bulk update given objects using one query over Django ORM.")
+ (license license:expat)))
+
+(define-public python2-django-bulk-update
+ (package-with-python2 python-django-bulk-update))