summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-03-19 23:47:50 +0000
committerChristopher Baines <mail@cbaines.net>2020-03-19 23:47:50 +0000
commit9ae3e79172ad0435bf47afee3ed707d56bb28907 (patch)
tree4da85bf5d79e52723a937d18a37e6f53b68ac129 /gnu/packages/django.scm
parent29a2f61e9704949cd6cda57aba11f0213104db6b (diff)
downloadguix-patches-9ae3e79172ad0435bf47afee3ed707d56bb28907.tar
guix-patches-9ae3e79172ad0435bf47afee3ed707d56bb28907.tar.gz
gnu: Add python-easy-thumbnails.
* gnu/packages/django.scm (python-easy-thumbnails): New variable.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 0652ea15e6..70b6662a9e 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -223,6 +223,30 @@ with arguments to the field constructor.")
"Django-taggit is a reusable Django application for simple tagging.")
(license license:bsd-3)))
+(define-public python-easy-thumbnails
+ (package
+ (name "python-easy-thumbnails")
+ (version "2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "easy-thumbnails" version))
+ (sha256
+ (base32
+ "14gzp5cv24z0qhxb7f7k7v9jgzpaj4n8yhjq83ynpx8183fs1rz4"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-django" ,python-django)
+ ("python-pillow" ,python-pillow)))
+ (home-page "https://github.com/SmileyChris/easy-thumbnails")
+ (synopsis "Easy thumbnails for Django")
+ (description
+ "Easy thumbnails is a Django plugin to dynamically create thumbnails
+based on source images. Multiple thumbnails can be created from a single
+source image, using different options to control parameters like the image
+size and quality.")
+ (license license:bsd-3)))
+
(define-public python-pytest-django
(package
(name "python-pytest-django")