summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-23 15:37:15 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-23 15:40:12 +0100
commit74eee9f27da6a9d76281de57c40a78a2495ce843 (patch)
tree1472dfd0931cce97099ecdcc85a95389cd7d5c66 /gnu/packages/django.scm
parent63e633c6f69d4613bfb27d85c78f2b85fe3a5586 (diff)
downloadguix-patches-74eee9f27da6a9d76281de57c40a78a2495ce843.tar
guix-patches-74eee9f27da6a9d76281de57c40a78a2495ce843.tar.gz
gnu: python-django-pipeline: Fix tests.
* gnu/packages/django.scm (python-django-pipeline)[arguments]: Set PYTHONPATH before running tests.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index a8e0277e95..7cd4c3f784 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -695,6 +695,9 @@ project.")
(or
(not tests?)
(begin
+ (setenv "PYTHONPATH"
+ (string-append (getcwd) ":"
+ (getenv "PYTHONPATH")))
(setenv "DJANGO_SETTINGS_MODULE" "tests.settings")
(invoke "django-admin" "test" "tests"))))))))
(propagated-inputs